This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 179006 - Boot error with xfs
Boot error with xfs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: chkfontpath (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
: 179813 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-01-26 09:05 EST by Tony Molloy
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 07:13:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tony Molloy 2006-01-26 09:05:32 EST
Description of problem:

When booting xfs starts with an error. There is an extra line in the
/etc/X11/fs/config file which should be removed

        /usr/share/fonts/default/Type1,
>>        default-point-size = 120         <<
        ,


Version-Release number of selected component (if applicable):

xorg-x11-xfs-1.0.0-2

How reproducible:

Always

Steps to Reproduce:
1. Boot system and watch boot messages
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike A. Harris 2006-01-27 17:33:01 EST
Was this a new OS installation of FC5test2, or was it an upgrade from a
previous OS release or test release?  If upgrade, what was the original
OS release installed?

The xfs config file as supplied, does have that line present in it
intentionally, and always has.

It appears that your config file somehow got corrupted, however it isn't
clear how that might have happened.

Have you ever hand modified the xfs config file prior to upgrading the
system?  Some of the utilities/scripts that modify the xfs config file,
expect it to be in a stricter format than xfs itself does, and may mangle
the config file if it has been modified by hand in a way the scripting
does not anticipate.

Anyhow, these are just some ideas off the top of my head to brainstorm
what might cause this problem to occur for you, however I draw no
conclusions yet, as there isn't yet enough information to conclude
anything.

We'll need a reproduceable test case to be able to diagnose the problem,
if it is a real bug in something though.

Please attach a copy of the original broken config file for examination,
and any other forensic data that might be useful in diagnosis.  Attach
as a bugzilla file attachment (not cut and paste).

Thanks in advance.
Comment 2 Tony Molloy 2006-01-30 09:01:56 EST
Mike,

I did a clean default install of Fc5-t2 from the iso's this morning and the
config file was OK.

catalogue = /usr/share/X11/fonts/misc:unscaled,
            /usr/share/X11/fonts/75dpi:unscaled,
            /usr/share/X11/fonts/100dpi:unscaled,
            /usr/share/X11/fonts/Type1,
            /usr/share/fonts/default/Type1,

# in 12 points, decipoints
default-point-size = 120

Then I ran "yum --exclude=\*debuginfo\* install xorg*" to install all the xorg
packages.

Now the config file is corrupt

catalogue = /usr/share/X11/fonts/misc:unscaled,
        /usr/share/X11/fonts/75dpi:unscaled,
        /usr/share/X11/fonts/100dpi:unscaled,
        /usr/share/X11/fonts/Type1,
        /usr/share/X11/fonts/TTF,
        /usr/share/X11/fonts/OTF,
        /usr/share/fonts/default/Type1,
        ,
        default-point-size = 120,
        /usr/share/fonts/chinese/TrueType,

Note the extra default-point-size line in the middle of the font catalogue

So it would appear that installing one of the non default xorg packages corrupts
the config file.


Tony Molloy

Additional Comments: 
Comment 3 Mike A. Harris 2006-01-31 12:13:33 EST
Ok, this is an unfortunate and nasty problem.  ;o/

It appears that chkfontpath must be to blame, as I can't think of any other
logical explanation.  Since the problem is new to FC5, my best hypothesis
is that chkfontpath is getting compiled differently with the newer gcc which
is in rawhide, uncovering bugs in the code.  The reason I suggest this is
likely the case, is because the chkfontpath code is the only thing that
touches that part of the xfs config file, and chkfontpath is known to have
rather poorly written code.

This is definitely something for the FC5Blocker list.  Thanks for the
report, and additional info!

Reassigning to chkfontpath component, under above assumption for deeper
investigation.
Comment 4 Mike A. Harris 2006-02-05 17:15:39 EST
*** Bug 179813 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2006-02-16 10:39:08 EST
Here is a sample xfs config catalogue:

catalogue = /usr/share/X11/fonts/misc:unscaled,
        /usr/share/X11/fonts/75dpi:unscaled,
        /usr/share/X11/fonts/100dpi:unscaled,
        /usr/share/X11/fonts/Type1,
        /usr/share/X11/fonts/TTF,
        /usr/share/X11/fonts/OTF,
        /usr/share/fonts/default/Type1,

# in 12 points, decipoints
default-point-size = 120




I think what is happening, is that something is causing the blank line to
be removed, resulting in:

catalogue = /usr/share/X11/fonts/misc:unscaled,
        /usr/share/X11/fonts/75dpi:unscaled,
        /usr/share/X11/fonts/100dpi:unscaled,
        /usr/share/X11/fonts/Type1,
        /usr/share/X11/fonts/TTF,
        /usr/share/X11/fonts/OTF,
        /usr/share/fonts/default/Type1,
# in 12 points, decipoints
default-point-size = 120


Here is my /theory/ as to what is happening:

I think the comma on the last font path element line, is causing the
chkfontpath parser to think there is another element.  It ignores comments,
so it parses "default-point-size = 120" as a font path element when reading
the config file into memory.  It gets weighted as a middle weight element,
and written into the middle of the catalogue when the file is written out.

This is just a /theory/ however, as I haven't reproduced the issue yet
unfortunately.  If someone who can reproduce this reliably, could give
specific instructions on how to do so, without having to do an OS install
or upgrade, such as just upgrading a single package causes this to happen,
that would be very helpful in figuring this out.

In the mean time, I am going to experiment with different things to see if
I can trigger specific bugs in the chkfontpath parser.

TIA
Comment 6 Mike A. Harris 2006-02-16 10:50:33 EST
I've tried the above config change, removed all the font packages, modified
the font path config to be empty except for the default entries, with no
space after them, reinstalled it all and the config file is in tact.

I need a 100% reproduceable test case in order to debug this.
Comment 7 Mike A. Harris 2006-02-21 10:29:34 EST
I just received the following email from a beta-tester:


Hi Mike,

I've just done an default install of FC5-t3 from the iso's and everything 
went OK. No problems with the font catalogue. 

Then I installed all the xorg packages

    yum --exclude=\*debuginfo\* install xorg\*

and the font catalogue was still intact.

I then installed everything from the base distribution and the font 
catalogue was still intact. So it looks like the xfs error
bugzilla 179006 is sorted.

Regards,

Tony

-- Tony Molloy. Dept. of Comp. Sci. University of Limerick
Comment 8 Yijun Yuan 2006-02-21 20:28:50 EST
Hi, Mike:

Would you please test this font RPM on fc5test3? I'm not sure if re-install it
multiple times is OK for fc5test3 'cause I cannot test it for now. Thanks!

http://gro.clinux.org/scm/cvsweb.php/rpms/w/wqy-bitmapfont/wqy-bitmapfont.spec?cvsroot=fedora
Comment 9 Mike A. Harris 2006-02-24 07:13:22 EST
It seems that whatever the problem was here, it was transient and has
been resolved in rawhide for a while now, as nobody is able to reproduce
the problem, and nobody has been reporting new reports of the problem
happening.

I'm closing this as "RAWHIDE" for now, however if it recurs, someone can
reopen the report and add as much detailed information about their system
as possible, including installation and upgrade history, how they upgraded
(yum or anaconda, etc.), what exact errors they saw (cut and pasted or
digital pictures), etc.


Note You need to log in before you can comment on or make changes to this bug.