Bug 1790819 - [IPI Baremetal] Coredns (infra pod) Corefile not updated if /etc/resolv.conf changed.
Summary: [IPI Baremetal] Coredns (infra pod) Corefile not updated if /etc/resolv.conf ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Yossi Boaron
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On:
Blocks: 1812526
TreeView+ depends on / blocked
 
Reported: 2020-01-14 10:05 UTC by Yossi Boaron
Modified: 2020-07-13 17:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Coredns infra pod forward DNS requests to servers list appears in /etc/resolv.conf file, in case /etc/resolv.conf file, is changed, the change doesn't reflect coredns Corefile. Consequence: Coredns don't forward DNS requests to the list of servers in /etc/resolv.conf Fix: Coredns-monitor pod will verify that Cordns forward list is synced with /etc/resolv.conf Result: Coredns will forward DNS requests to the list of servers appears in /etc/resolv.conf
Clone Of:
Environment:
Last Closed: 2020-07-13 17:13:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:13:43 UTC

Description Yossi Boaron 2020-01-14 10:05:38 UTC
Description of problem:
Coredns infra pod should forward requests to servers list that retrieved from /etc/resolv.conf file. 

If /etc/resolv.conf file is changed, the change doesn't reflect coredns Corefile.
Version-Release number of selected component (if applicable):


How reproducible:

Change /etc/resolv.conf servers list
Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Kirsten Garrison 2020-01-15 00:19:59 UTC
Antoni, could you or one of the baremetal folks take a look at this?

As this has to do with templates (baremetal-coredns.yaml) in the MCO repo, but we don't actually own them...

Comment 2 Kirsten Garrison 2020-01-15 18:17:47 UTC
Talked to Brad and he suggested I move this to KNI-Deployment.

Comment 3 Antonio Murdaca 2020-03-11 14:34:09 UTC
PR for 4.5 (this BZ) was incorrectly titled w/o the correct "Bug ######:" prefix therefore the bot didn't attach the PR, but it's here https://github.com/openshift/machine-config-operator/pull/1501

Comment 8 Victor Voronkov 2020-03-19 06:40:33 UTC
Verified on 4.5.0-0.nightly-2020-03-18-115438

[core@master-0 ~]$ cat /var/run/NetworkManager/resolv.conf 
# Generated by NetworkManager
nameserver fe80::5054:ff:fe4f:98a6%enp5s0
nameserver fd2e:6f44:5dd8:c956::1

[core@master-0 ~]$ cat /etc/coredns/Corefile | grep forward
    forward . fe80::5054:ff:fe4f:98a6%enp5s0 fd2e:6f44:5dd8:c956::1


# added 192.168.123.1 to resolv.conf and after few seconds corefile got updated

[core@master-0 ~]$ cat /etc/coredns/Corefile | grep forward
    forward . fe80::5054:ff:fe4f:98a6%enp5s0 fd2e:6f44:5dd8:c956::1
    forward . fe80::5054:ff:fe4f:98a6%enp5s0 fd2e:6f44:5dd8:c956::1 192.168.123.1

Comment 10 errata-xmlrpc 2020-07-13 17:13:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.