Bug 1812526 - [IPI Baremetal] Coredns (infra pod) Corefile not updated if /etc/resolv.conf changed
Summary: [IPI Baremetal] Coredns (infra pod) Corefile not updated if /etc/resolv.conf ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Yossi Boaron
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On: 1790819
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 14:03 UTC by Yossi Boaron
Modified: 2020-05-04 11:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:45:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift baremetal-runtimecfg pull 51 None closed Bug 1812526: [release-4.4] Add support for coredns watcher 2020-06-03 17:17:32 UTC
Github openshift machine-config-operator pull 1557 None closed Bug 1812526: [release-4.4] baremetal: Add watcher sidecar container for Coredns static pod 2020-06-03 17:17:32 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:46:15 UTC

Description Yossi Boaron 2020-03-11 14:03:17 UTC
Description of problem:
Duplicate https://bugzilla.redhat.com/show_bug.cgi?id=1790819 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 8 Victor Voronkov 2020-03-27 14:12:31 UTC
Verified on 4.4.0-0.nightly-2020-03-27-042715

[core@master-0 ~]$ cat /var/run/NetworkManager/resolv.conf 
# Generated by NetworkManager
search ocp-edge-cluster.qe.lab.redhat.com
nameserver 192.168.123.1

[core@master-0 ~]$ cat /etc/coredns/Corefile | grep forward
    forward . 192.168.123.1

added to resolv.conf a line:
nameserver 172.22.0.2

[core@master-0 ~]$ cat /etc/coredns/Corefile | grep forward
    forward . 192.168.123.1
[core@master-0 ~]$ cat /etc/coredns/Corefile | grep forward
    forward . 192.168.123.1
[core@master-0 ~]$ cat /etc/coredns/Corefile | grep forward
    forward . 192.168.123.1
[core@master-0 ~]$ cat /etc/coredns/Corefile | grep forward
    forward . 192.168.123.1 172.22.0.2

Comment 10 errata-xmlrpc 2020-05-04 11:45:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.