Bug 179158 - Installer crashes in post-install
Installer crashes in post-install
Status: CLOSED DUPLICATE of bug 139146
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
James Laska
Depends On:
  Show dependency treegraph
Reported: 2006-01-27 15:43 EST by Soren Juelsgaard
Modified: 2013-09-02 02:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-27 20:31:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda text dump (1.39 MB, text/plain)
2006-01-27 15:46 EST, Soren Juelsgaard
no flags Details

  None (edit)
Description Soren Juelsgaard 2006-01-27 15:43:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:

The installer crashes in the post install with the following message:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 1204, in doPostInstall
    stdout = devnull)
  File "/usr/lib/anaconda/iutil.py", line 53, in execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /usr/sbin/kudzu can not be run

Please see attached anaconda dump.

I have tried with two different hard drives - one SATA and one EIDE.
I have tried minimum installs and "everything" installs.
I have tried automatic Druid partitioning of disks, I have tried manual Druid, I have tried fdisk partitioning.

I am not sure if this bug is related to bug #170003

I find it curious that the text install has all the error messages from rpmdb ("rpmdb: PANIC: fatal region error detected: run recovery").

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start CD install
2a. pick graphic install
3a. watch in tears how the post-install crashes
2b. pick text-mode install
3b. installer crashes with "rpmdb: PANIC: fatal region error detected: run recovery" spewing all over the screen while installing packages.

Additional info:
Comment 1 Soren Juelsgaard 2006-01-27 15:46:12 EST
Created attachment 123792 [details]
anaconda text dump
Comment 3 Soren Juelsgaard 2006-01-27 17:32:42 EST
My system is a P4 1.7GHz system, and I believe that it is a copy of an older FC3
bug: #139146
Comment 4 Chris Lumens 2006-01-27 20:31:13 EST

*** This bug has been marked as a duplicate of 139146 ***

Note You need to log in before you can comment on or make changes to this bug.