Bug 1791855 - [Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-default token max age to generate tokens that do not expire works as expected when using a code authorization flow
Summary: [Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-defa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.z
Assignee: Standa Laznicka
QA Contact: scheng
URL:
Whiteboard:
Depends On: 1765733
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-16 15:49 UTC by Jeff Peeler
Modified: 2020-04-07 17:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-07 17:34:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1263 None None None 2020-04-07 17:34:06 UTC

Description Jeff Peeler 2020-01-16 15:49:36 UTC
Description of problem:
fail [github.com/openshift/origin/test/extended/oauth/expiration.go:141]: Expected
    <int>: 500
to equal
    <int>: 302


How reproducible:
Rare


Possibly related to https://bugzilla.redhat.com/show_bug.cgi?id=1765733. If so, perhaps https://github.com/openshift/origin/pull/24239 should be backported to the 4.2 branch too.

Comment 2 Scott Dodson 2020-03-19 19:08:28 UTC
3 occurrences over past 48hrs, bumping to medium

Comment 7 errata-xmlrpc 2020-04-07 17:34:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1263


Note You need to log in before you can comment on or make changes to this bug.