Bug 179193 - Replication UI most of the time don't return consumer initialization error
Replication UI most of the time don't return consumer initialization error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Directory Server
Classification: Red Hat
Component: UI - Configuration (Show other bugs)
7.1
All Linux
medium Severity medium
: DS8.1
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
: 200989 (view as bug list)
Depends On:
Blocks: 152373 249650 FDS1.2.0
  Show dependency treegraph
 
Reported: 2006-01-27 18:35 EST by To Ngan
Modified: 2015-01-04 18:19 EST (History)
5 users (show)

See Also:
Fixed In Version: 8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 18:58:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs (3.26 KB, patch)
2008-12-15 15:29 EST, Rich Megginson
no flags Details | Diff
cvs commit log (541 bytes, text/plain)
2008-12-15 16:05 EST, Rich Megginson
no flags Details

  None (edit)
Description To Ngan 2006-01-27 18:35:16 EST
Description of problem:
Replication UI most of the time don't return consumer initialization error

Version-Release number of selected component (if applicable):
DS 7.1 SP1

How reproducible:
Most of the time

Steps to Reproduce:
1. Setup replication agreement through console.  Make it such that the bind DN
or passwd is wrong, or the consumer is another Master, such that the
initialization will always fail.
2. Pick to initialize consumer now.
3. More often than not when user click on Done button on the Summary dialog, a
dialog with "Consumer Initialization Started" title comes up stating the
initialization has been successfully started.

Only once in a while do I actually get the expected error dialog.  Not sure why
this inconsistency happens.
Comment 2 Chandrasekar Kannan 2007-10-18 02:22:15 EDT
*** Bug 200989 has been marked as a duplicate of this bug. ***
Comment 4 Rich Megginson 2008-12-15 15:29:26 EST
Created attachment 327021 [details]
diffs
Comment 5 Rich Megginson 2008-12-15 16:05:56 EST
Created attachment 327025 [details]
cvs commit log

Reviewed by: nkinder (Thanks!)
Fix Description: Just added a 3 second sleep after telling the server to perform the consumer init.  This seems to give the server time enough to attempt the init, fail, and set an appropriate error code.
Platforms tested: RHEL5
Flag Day: no
Doc impact: no
Comment 6 Jenny Galipeau 2009-03-11 12:04:54 EDT
fix verified:  RHEL5

Repeated attempts to add a new agreement with invalid credentials all produced errors on initialization.
Comment 7 Chandrasekar Kannan 2009-04-29 18:58:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0455.html

Note You need to log in before you can comment on or make changes to this bug.