Bug 200989 - "Consumer server unreachable" message even though server is reachable
"Consumer server unreachable" message even though server is reachable
Status: CLOSED DUPLICATE of bug 179193
Product: 389
Classification: Community
Component: Replication - General (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
Depends On:
Blocks: 152373 240316
  Show dependency treegraph
Reported: 2006-08-01 20:25 EDT by Daniel Lipsitt
Modified: 2015-01-04 18:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-18 02:22:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Lipsitt 2006-08-01 20:25:08 EDT
Description of problem:
When I create a replication agreement, I get a dialog saying:

"Consumer server unreachable or invalid credentials supplied. Unable to perform
subtree duplication verification. Do you wish to continue?"

If I continue, the replication nonetheless occurs. The error message appears
immediately, which made me suspect that the reachability test does not occur. I
attempted a packet capture with ethereal, and saw no traffic to the consumer on
port 389 or 636. I see the message even though I supply the correct credentials.
I believe it also occurs no matter what port I select.

Version-Release number of selected component (if applicable):

Steps to Reproduce:
1. New replication agreement
2. select "Using encrypted SSL connection"
3. Enter bind and password info
4. click Next
Comment 1 Rich Megginson 2006-09-05 17:07:52 EDT
Try to reproduce using ldapsearch from the command line.
cd /opt/fedora-ds/shared/bin
./ldapsearch -h remotehost -p remoteport -Z -P
/opt/fedora-ds/alias/slapd-yourhost-cert8.db -D "repl manager DN" -w
replmanpassword -s base -b "" "objectclass=*"
Comment 2 Daniel Lipsitt 2006-09-05 17:24:33 EDT
I get:

SSL initialization failed: error -8174 (security library: bad database.)
Comment 3 Rich Megginson 2006-09-05 17:39:39 EDT
Is replication working?
Comment 4 Daniel Lipsitt 2006-09-07 14:17:43 EDT
Yes, replication is working.
Comment 5 Rich Megginson 2006-09-07 14:21:48 EDT
Ok.  I'm trying to gauge the severity of this issue.  It sounds like a low
severity i.e. it's just some random (possibly bogus) error message in the
console when setting up the replication agreement.  Other than that, everything
seems to be working fine?
Comment 6 Daniel Lipsitt 2006-09-07 15:16:02 EDT
Yes, things seem to work fine if you ignore the message. If you don't know that
you can ignore it, it prevents you from setting up replication at all.

By the way, I see that I didn't mention that my supplier is x86_64 and my
consumer is x86. I don't know whether that's significant.
Comment 7 Chandrasekar Kannan 2007-10-18 02:22:14 EDT

*** This bug has been marked as a duplicate of 179193 ***

Note You need to log in before you can comment on or make changes to this bug.