This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 179198 - gnome-system-log quits unexpectedly
gnome-system-log quits unexpectedly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-utils (Show other bugs)
rawhide
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-01-27 19:06 EST by Émeric Maschino
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 00:25:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gnome-system-log crash callstack (1.81 KB, text/plain)
2006-04-02 07:03 EDT, Émeric Maschino
no flags Details

  None (edit)
Description Émeric Maschino 2006-01-27 19:06:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ia64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Invoking gnome-system-log (either by GUI or CLI) ends up with a dialog box stating that gnome-system-log quits unexpectedly. On the console, the following message is displayed:

(gnome-system-log:8515): GConf-CRITICAL **: gconf_client_get_list: assertion `err == NULL || *err == NULL' failed

Version-Release number of selected component (if applicable):
gnome-utils 2.13.5-3

How reproducible:
Always

Steps to Reproduce:
1. Start up gnome-system-log from the CLI
2.
3.
  

Additional info:
Comment 1 Frank Arnold 2006-01-27 23:00:11 EST
Already fixed in GNOME CVS:
http://bugzilla.gnome.org/show_bug.cgi?id=327614

But why does it crash? Without --g-fatal-warnings it should not crash, and does
not on my PPC laptop.
Comment 2 Matthias Clasen 2006-02-06 10:54:15 EST
Should be fixed in rawhide
Comment 3 Émeric Maschino 2006-02-08 03:03:55 EST
Sorry, gnome-system-log is still crashing (tried gnome-utils-2.13.91-1 and
gnome-utils-2.13.91-2). Furthermore, I'm no more getting an output on the
console. The annoying thing is that even with debuginfo packages installed
(actual attr-debuginfo-2.4.28-1, glib2-debuginfo-2.9.5-1,
glibc-debuginfo-2.3.90-36, gnome-utils-debuginfo-2.13.91-2,
libselinux-debuginfo-1.29.6-1 and libsepol-debuginfo-1.11.12-1), I can't get a
stacktrace (I followed the directions in the Fedora Wiki page). What's missing
so that I can produce a stracktrace in order to help solve the problem?
Comment 4 Frank Arnold 2006-02-08 07:28:24 EST
FYI, there's another crasher filed in bug 179688.

To get a backtrace with gdb run 'gdb /usr/sbin/gnome-system-log' as root.
Otherwise the consolehelper stuff gets in your way. 

This particular bug should be fixed. Better to open a new one or comment on bug
179688, if that's your current problem.
Comment 5 Émeric Maschino 2006-02-08 08:27:35 EST
(In reply to comment #4)
> FYI, there's another crasher filed in bug 179688.
> 
> To get a backtrace with gdb run 'gdb /usr/sbin/gnome-system-log' as root.
> Otherwise the consolehelper stuff gets in your way. 
> 
> This particular bug should be fixed. Better to open a new one or comment on bug
> 179688, if that's your current problem.

Thanks for your report on bug 179688. I don't know if bug 179688 is related to
this one: indeed, comment #5 of bug 179688 states that gnome-utils-2.13.91-2 is
fine, which isn't the case here. I've installed the debuginfo packages listed in
my previous post (comment #3) and ran gdb gnome-system-log as root or as a user.
Unfortunately, bt pretends there's no stack and thread apply all bt has no
output at all. I'm probably missing a debuginfo package, but which one? In order
to determine which debuginfo package install, I've run ldd
/usr/bin/gnome-system-log. Only when I have a stacktrace, I may be able to check
whether this bug is similar/related to 179688 or not.
Comment 6 Frank Arnold 2006-02-08 09:30:28 EST
Debuginfo packages won't help in that case. They only make the backtrace more
informative. But first there must be a backtrace available at all. A backtrace
without debuginfo packages looks like bug 133969 comment #1 for instance.

In your case the program seems to exit "normally". Or you forgot to start the
program with "run" inside gdb before doing a "bt", but I doubt that...
Comment 7 Émeric Maschino 2006-02-08 14:26:45 EST
Here's my mistake: running gdb gnome-system-log as root ends up with no stack
but a dialog box telling me that gnome-system-log quits unexpectedly. However,
running gdb /usr/sbin/gnome-system-log made the difference: the dialog box isn't
displayed but at least I can get a backtrace that seems to be different from the
one in bug 179688:

#0  0x20000000012ae020 in IA__g_type_check_instance_cast (
    type_instance=0x60000000000cc100, iface_type=824432) at gtype.c:2692
#1  0x4000000000010e00 in logview_init (logview=0x6000000000073000)
    at logview.c:829
#2  0x20000000012b8900 in IA__g_type_create_instance (type=0) at gtype.c:1567
#3  0x200000000127a200 in g_object_constructor (type=6917529027641468752,
    n_construct_properties=1, construct_params=0x60000000000723f0)
    at gobject.c:1015
#4  0x2000000001275380 in IA__g_object_newv (object_type=6917529027641468752,
    n_parameters=468008, parameters=Variable "parameters" is not available.
) at gobject.c:912
#5  0x2000000001276ad0 in IA__g_object_new_valist (
    object_type=6917529027641468752, first_property_name=0x0, var_args=Variable
"var_args" is not available.
)
    at gobject.c:955
#6  0x2000000001276ea0 in IA__g_object_new (object_type=6917529027641468752,
    first_property_name=0x0) at gobject.c:793
#7  0x4000000000010130 in logview_window_new () at logview.c:986
#8  0x4000000000009a00 in main (argc=1, argv=0x60000fffff90b7e8) at main.c:159
#9  0x20000000016831c0 in __libc_start_main (main=Cannot access memory at
address 0x1
) at libc-start.c:231
#10 0x4000000000009580 in _start ()
#11 0x0000000000000000 in ?? ()

This is with up-to-date packages (attr-2.4.28-1, glib2-2.9.5-1, glibc-2.3.90-36,
gnome-utils-2.13.91-2, libselinux-1.29.6-1, libsepol-1.11.12-1), just before
"the massive rebuilt" was announced and I was advised to wait until all packages
have been rebuilt before upgrading my system to the latest packages.
Comment 8 Émeric Maschino 2006-02-09 17:34:26 EST
Exactly the same problem and stacktrace with up-to-date Rawhide and
gnome-utils-2.13.91-2.1
Comment 9 Émeric Maschino 2006-04-02 07:03:38 EDT
Created attachment 127201 [details]
gnome-system-log crash callstack
Comment 10 Émeric Maschino 2006-04-02 07:06:03 EDT
gnome-system-log (from gnome-utils-2.14.0-3) is still crashing. It seems there's
something wrong with glib2 (this is with glib2-2.10.1-1). The relevant callstack
is provided in attachment 127201 [details].
Comment 11 Émeric Maschino 2006-06-14 18:27:50 EDT
gnome-system-log is no more crashing and is working fine :-) This is with
gnome-utils-2.15.3-1. In my opinion, this bug report can now be safely closed.
Manu thank.

Note You need to log in before you can comment on or make changes to this bug.