Bug 179219 - Language settings in "Tools" + "Options" greyed out
Language settings in "Tools" + "Options" greyed out
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 179220 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-28 08:39 EST by mp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-28 09:45:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mp 2006-01-28 08:39:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051202 Fedora/1.5-0.fc4 Firefox/1.5

Description of problem:
If you go to TOOLS / OPTIONS / LANGUAGE SETIINGS the option for setting the deafult language is greyed out, which means it set to US_ENGLISH.

It means that every time you do a spell check the language is set to US-English.

This has been an issue for a while, across versions, but only came with FC OOo1.9 versions, but persists?

I just noticed that in the Ubuntu OOo package this bug has been fixed and there is even an option to tick called "Load OOd on startup to speed up etc etc".



Version-Release number of selected component (if applicable):
this has been an issue for a while, across versions

How reproducible:
Always

Steps to Reproduce:
1. open OOo, click TOOLS / OPTIONS / LANGUAGE
2. always grey
3.
  

Actual Results:  the greyed out field appears

Expected Results:  user shoulod be able to set the language to whatever s/he wants

Additional info:
Comment 1 Caolan McNamara 2006-01-28 09:39:58 EST
*** Bug 179220 has been marked as a duplicate of this bug. ***
Comment 2 Caolan McNamara 2006-01-28 09:45:21 EST
This is by design, setting the default language is "locked" except on a
per-document basis. The Fedora OOo always takes its default language from the
active locale, so if you are running OOo under an US english locale, it defaults
to US english. If you set your locale to something different then OOo like the
majority of applications will use the active locale language.

You can override the default language on a per document basis in OOo, but to set
the default language in OOo you should set the desired default language for your
entire session.

e.g. from a terminal 

> export LANG=de_DE.UTF-8
> oowriter

and writer defaults to the german spell-checker

> export LANG=en_US.UTF-8
> oowriter

and writer defaults to the English US spell-checker

The intention is that someone who changes locale sees those changes reflected in
OOo similiar to how they change in e.g. gedit and so forth.
Comment 3 mp 2006-01-28 09:57:06 EST
i see!! interesting, thx

which leaves me having to google for how to change the default setting of the
system, then.
Comment 4 mp 2006-01-28 10:32:36 EST
thx, but your proposed solutions just don't do anything for me!

i have run OOo from konsole - exporting as suggested - but this changes nothing
for me! still runs in US mode, still defaults to US spell check, even if i
change the settings for the document i am working on (current document only)
then save, then close and reopen - it is back to US version

while i am used to the fact that the US Empire runs the world, i want it out of
my box!
Comment 5 Caolan McNamara 2006-01-28 11:24:56 EST
> even if i change the settings for the document i am working on (current 
> document only) then save, then close and reopen - it is back to US version

Yes, OOo takes the default language from the locale LANG value, changing the
language of the current document changes only the current document not future
ones. This the same behaviour as gedit, i.e. you can set the current language
for spellchecking, but on exit and restart it again will take the language from
the "LANG" variable.

What language do you *want* ?

Currently, change to a terminal and 
> echo $LANG
whatever that says is whatever language was selected as the default language
during fedora installation, undoubtedly it says "en_US.UTF-8" And this is thus
the default language gedit and OOo will use for spellchecking

Under gnome "Desktop->System Settings->Language" sets this default language
(i.e. edits /etc/sysconfig/i18n for you) after setting the language you actually
want, then logout and login again.

e.g. https://www.redhat.com/archives/fedora-list/2004-December/msg01419.html for
some possibly useful help
Comment 6 mp 2006-01-28 13:52:33 EST
thanks! and sorry for making a nuisance of myself.

i do understand the concept/principle - but running OOo from konsole after
exporting the desired language setting - which is, for me, UK/GB English -
didn't help!?!?  OOo still opened up and spell checked by default in US English.

However, the link you provided was very helpful - with the syntax for editing
/etc/sysconfig/i18n i have been able to add GB English. Now I just have to log
out and back in to confirm that it does the job.

thanks (hoping that it works)

:)
Comment 7 Caolan McNamara 2006-01-28 16:06:37 EST
for you then you need.

LANG="en_GB.UTF-8"

My own locale is "en_IE.UTF-8" which shares the same dictionaries as
"en_GB.UTF-8" and I know that locale works to default OOo to non US english
spelling :-)

Note You need to log in before you can comment on or make changes to this bug.