Bug 1792334 - oc adm must-gather does not gather endpoint resources
Summary: oc adm must-gather does not gather endpoint resources
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
: 1801280 (view as bug list)
Depends On: 1792330
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-17 14:26 UTC by Maciej Szulik
Modified: 2020-03-10 23:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1792330
Environment:
Last Closed: 2020-03-10 23:53:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 263 None closed [release-4.3] Bug 1792334: pods that are no longer running can still have logs 2020-03-04 21:12:33 UTC
Github openshift oc pull 264 None closed [release-4.3] Bug 1792334: collect endpoints for namespaces 2020-03-04 21:12:33 UTC
Red Hat Product Errata RHBA-2020:0676 None None None 2020-03-10 23:53:44 UTC

Description Maciej Szulik 2020-01-17 14:26:03 UTC
+++ This bug was initially created as a clone of Bug #1792330 +++

As stated in the title, when invoked oc adm must-gather doesn't collect data about endpoints.

Comment 1 Maciej Szulik 2020-02-11 09:07:21 UTC
*** Bug 1801280 has been marked as a duplicate of this bug. ***

Comment 4 zhou ying 2020-03-02 09:46:37 UTC
Confirmed with latest oc client, the issue has fixed:
[root@dhcp-140-138 ~]#  oc version -o yaml 
clientVersion:
  buildDate: "2020-02-28T07:04:58Z"
  compiler: gc
  gitCommit: c25fb9c7db26b5aaf123a9da0b8fc9f95b2dff92
  gitTreeState: clean
  gitVersion: 4.3.5-202002280657-c25fb9c
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64


[root@dhcp-140-138 namespaces]# tree openshift-monitoring/core/
openshift-monitoring/core/
├── configmaps.yaml
├── endpoints.yaml
├── events.yaml
├── persistentvolumeclaims.yaml
├── pods.yaml
├── replicationcontrollers.yaml
├── secrets.yaml
└── services.yaml

Comment 6 errata-xmlrpc 2020-03-10 23:53:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676


Note You need to log in before you can comment on or make changes to this bug.