Bug 1792416 - Cancelled Pipeline Runs Show As Failed
Summary: Cancelled Pipeline Runs Show As Failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1792419
TreeView+ depends on / blocked
 
Reported: 2020-01-17 15:58 UTC by Andrew Ballantyne
Modified: 2020-05-04 11:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Cancelled Pipelines are Failed Pipelines with a reason of "Cancelled"... we just didn't handle the reason Consequence: Showed Cancelled Pipelines as Failed Fix: Check the reason why it failed Result: Show a Cancelled state when the reason for a failure was it was Cancelled.
Clone Of:
: 1792419 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:24:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
Cancelled pipelines are listing down in cancelled pipeline menu (137.09 KB, image/png)
2020-01-20 07:28 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:25:35 UTC

Description Andrew Ballantyne 2020-01-17 15:58:29 UTC
Description of problem:
When the user cancels a PipelineRun, the UI shows this status as failed not cancelled despite the underlying data saying otherwise.


Version-Release number of selected component (if applicable):
OpenShift Console 4.4 
Pipeline Operator 0.8.x


How reproducible:
!00%

Steps to Reproduce:
1. Create a Pipeline with at least one task
2. Start the Pipeline
3. Stop the Pipeline before it finishes all the tasks

Actual results:
PipelineRun shows up as failed in the statuses (Pipeline Table (latest run), PipelineRun Table, etc)

Expected results:
PipelineRun should show up as Cancelled and use the cancelled colour.

Additional info:

Comment 1 Andrew Ballantyne 2020-01-17 16:02:13 UTC
Gajanan please review this as an extension of your review here: https://issues.redhat.com/browse/ODC-2423

Comment 2 Gajanan More 2020-01-20 07:27:27 UTC
I have validated this bug on the,
Build: 4.4.0-0.ci-2020-01-16-043412
Browser: Google Version 78.0.3904.108
Please check the attached screenshot

Comment 3 Gajanan More 2020-01-20 07:28:06 UTC
Created attachment 1653834 [details]
Cancelled pipelines are listing down in cancelled pipeline menu

Comment 5 errata-xmlrpc 2020-05-04 11:24:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.