Bug 1792419 - Cancelled Pipeline Runs Show As Failed
Summary: Cancelled Pipeline Runs Show As Failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1792416
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-17 16:03 UTC by Andrew Ballantyne
Modified: 2020-02-19 05:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1792416
Environment:
Last Closed: 2020-02-19 05:39:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
Pipeline Runs Show Cancelled Status (240.94 KB, image/png)
2020-02-13 02:58 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3993 None closed [release-4.3] Bug 1792419: fix(pipeline-tasks): Cancelled tasks 2020-02-11 13:43:04 UTC
Red Hat Product Errata RHBA-2020:0492 None None None 2020-02-19 05:40:06 UTC

Description Andrew Ballantyne 2020-01-17 16:03:21 UTC
+++ This bug was initially created as a clone of Bug #1792416 +++

Description of problem:
When the user cancels a PipelineRun, the UI shows this status as failed not cancelled despite the underlying data saying otherwise.


Version-Release number of selected component (if applicable):
OpenShift Console 4.4 
Pipeline Operator 0.8.x


How reproducible:
!00%

Steps to Reproduce:
1. Create a Pipeline with at least one task
2. Start the Pipeline
3. Stop the Pipeline before it finishes all the tasks

Actual results:
PipelineRun shows up as failed in the statuses (Pipeline Table (latest run), PipelineRun Table, etc)

Expected results:
PipelineRun should show up as Cancelled and use the cancelled colour.

Additional info:

--- Additional comment from Andrew Ballantyne on 2020-01-17 16:02:13 UTC ---

Gajanan please review this as an extension of your review here: https://issues.redhat.com/browse/ODC-2423

Comment 1 Andrew Ballantyne 2020-01-20 19:31:11 UTC
PR pending 4.3.z release to open up: https://github.com/openshift/console/pull/3993

Comment 3 Yadan Pei 2020-02-13 02:58:57 UTC
Created attachment 1662845 [details]
Pipeline Runs Show Cancelled Status

1. Enable OpenShift Pipelines Operator
2. Create Pipelines and trigger Pipeline Runs
3. Stop Pipeline Runs before all stages finish
4. Check Pipeline Runs status in Pipeline Runs list page, table, status Filter. All shows 'Cancelled' with grey color

verified on     4.3.0-0.nightly-2020-02-11-224725

Comment 4 Yadan Pei 2020-02-13 03:00:16 UTC
Sorry it looks like I changed assignee by mistake, reverted it back

Comment 6 errata-xmlrpc 2020-02-19 05:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0492


Note You need to log in before you can comment on or make changes to this bug.