Bug 179246 - System hangs - mostly during bootup
System hangs - mostly during bootup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-28 18:50 EST by Claus Olesen
Modified: 2015-01-04 17:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 15:45:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of dmesg referenced in comment #10 (18.03 KB, text/plain)
2006-11-22 00:03 EST, Claus Olesen
no flags Details

  None (edit)
Description Claus Olesen 2006-01-28 18:50:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.0 (like Gecko)

Description of problem:
My system hangs. I have not yet not experienced it not to hang and I've never     
seen it recover. It happens at random places - mostly during bootup at the     
stage where the system is starting various services - but a few times also     
after the desktop is running. 
      
Some of the "hangs" are silient. The console says      
Starting service abcxyz [OK]      
and then silence. 
    
Other "hangs" are followed by a message every 30 seconds -   
mostly this one   
ata1: command 0x35 timeout, stat 0x50 host_stat 0x24   
but also this one   
ata1: command 0x25 timeout, stat 0x50 host_stat 0x24   
     
I googled and then tried passing first noapic and then instead acpi=off as     
kernel argument. In both cases I have not yet experienced the problem.     
      
My system:      
OS: FC5Test2 x86_64     
Motherboard: MSI K8NGM-V (Nvidia C51G/MCP51G aka 6100/410)       
Harddisk: Hitachi HDT722525DLA380 (SATA 300)       
CPU: Sempron 2800      
Memory: 1GB  
Other hardware, cards, connections, etc: None - except PSU, vga, mouse,  
keyboard and Ethernet. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC5Test2 on hardware as described in the "Description"  
2. Boot 
3. 
   

Actual Results:  The system hung. 

Expected Results:  The system should not have hung. 

Additional info:

The motherboard and chipset model is relatively new.
Comment 1 Rahul Sundaram 2006-02-20 05:49:10 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Dave Jones 2006-03-06 13:00:11 EST
was test3 any better ?
Comment 3 Claus Olesen 2006-03-06 21:45:31 EST
No. I did try fc5t3 and the problem is still there. I don't know what the 
adverse effects of the workaround "noapic acpi=off" are except I think it is 
the reason for power not being turned off automatically on shutdown. 
 
 
Comment 4 Claus Olesen 2006-03-31 01:52:23 EST
My other computer is identical to the above but runs FC4 i386. I just 
up2date'd both incl. latest kernel-2.6.16-1.2069_FC4. 
Results 
i386: 
It now exhibits the same above problem unless I pass "noapic acpi=off". 
x86_64: 
It now hangs already right after having displayed "Booting the kernel." during 
bootup - whether or not I pass "noapic acpi=off". 
 
Comment 5 Claus Olesen 2006-04-02 13:27:04 EDT
Maybe this is helpful. I just tried both i386 and x86_64 of the latest SuSE - 
10.1 beta 9. And neither exhibits this problem. 
 
Comment 6 Claus Olesen 2006-04-29 02:55:33 EDT
Maybe also this is helpful.
I just again tried giving this problem another shot. This time with FC5 i386 
final but still on the same above hardware. FC5 final wouldn't even install. 
Hung at the point where it is about to install packages and also if I pass 
noapic acpi=off. I then searched the BIOS and found an option named IOAPIC. I 
disabled that and that did it. With that FC5 installed and runs - also without 
passing noapic acpi=off. I then reset the BIOS back to factory defaults i.e. 
re-enabled the IOAPIC option. With that FC5 again hangs and the console says
"ACPI: Unable to load the System Description Tables" but if I then pass noapic 
acpi=off then the console does not show that message and FC5 does not hang.
Comment 7 Dave Jones 2006-10-16 16:46:17 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 8 Claus Olesen 2006-10-23 00:53:52 EDT
I have restarted many times and run without "noapic acpi=off" since notified 
by comment #7 - and the problem has not reoccurred.
Comment 9 Dave Jones 2006-11-20 14:14:26 EST
it would be interesting to know if you really need both those options.  If it's
jut the noapic option that's causing the problem to go away, there was a patch
in the update kernel I pushed out last week (2.6.18-1.2239.fc5) which may also
solve your problem without you passing any options at all.
Comment 10 Claus Olesen 2006-11-21 23:59:16 EST
I can't test because the problem no longer shows.

Again, I have 2 systems of identical hardware as specified above.
On one I still had the fc5 i386. I up2date'd it to 2.6.18-1.2239.fc5, rebooted 
it 10 times without "noapic" and "acpi=off", exercised it in between reboots 
and the problem did not show.
On the other I'm now running 2.6.18-1.2849.fc6 i386 and also without "noapic" 
and "acpi=off" and it doesn't have the problem anymore either.
I've attached the output of dmesg from the fc6 system - in case usefull.

The problem is solved as far as I can tell.
Comment 11 Claus Olesen 2006-11-22 00:03:21 EST
Created attachment 141870 [details]
output of dmesg referenced in comment #10

Note You need to log in before you can comment on or make changes to this bug.