Bug 17926 - Upgrade over 6.0 failed
Upgrade over 6.0 failed
Status: CLOSED DUPLICATE of bug 18031
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-29 21:42 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 15:06:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-29 21:42:52 EDT
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1543, in 
doInstall
    self.instCallback, p)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1298, in 
instCallback
    self.rpmFD = os.open(fn, os.O_RDONLY)
OSError: [Errno 2] No such file or 
directory: '/mnt/source/RedHat/RPMS/kernel-utils-2.2.16-22.i386.rpm'

Local variables in innermost frame:
fn: /mnt/source/RedHat/RPMS/kernel-utils-2.2.16-22.i386.rpm
total: 0
self: <todo.ToDo instance at 828fe58>
h: <header object at 8b07590>
amount: 0
intf: <progress_gui.InstallProgressWindow instance at 848b8c0>
what: 2

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>
Comment 1 Pekka Savola 2000-09-30 14:59:48 EDT
From the traceback, this would seem to be a problem with missing kernel-utils RPM, not the upgrade.
Comment 2 Michael Fulbright 2000-10-02 18:53:19 EDT
Definately sounds like a bad CD image. Please verify the file exists.
Comment 3 Need Real Name 2000-10-02 19:12:10 EDT
RPM does exist in the RPMS directory on the CD.  I burned the CD from ISO's D/L 
from redhat.com.

I now have it installed but did so as a fresh install.  Had no problems on 
fresh install.
Comment 4 Larason, Todd 2000-10-03 01:37:57 EDT
I had a very similar problem with an upgrade over 6.1; the 'missing file' was
rep-gtk-gnome-0.13-3.i386.rpm.  After rebooting and getting the system usable
again, I verified that the file was there (it was), and copied from the discs to
a harddrive with enough space.  A second upgrade attempt, working from the
harddrive, succeeded.

My CDs were also burnt from ISO images downloaded.  As I indicated, I had no
problem reading them to copy them to a HD when running under 6.1.
Comment 5 Michael Fulbright 2000-10-03 15:06:26 EDT

*** This bug has been marked as a duplicate of 18031 ***

Note You need to log in before you can comment on or make changes to this bug.