Bug 179286 - factory: build failure (gcc-4.1?)
factory: build failure (gcc-4.1?)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: factory (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target 183265
  Show dependency treegraph
 
Reported: 2006-01-29 15:52 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 11:53:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-01-29 15:52:00 EST
Description of problem:
factory doesn't build under current mock fc5/devel due to compiler issue

End of build.log: 

c++ -c int_poly.cc -w -fno-implicit-templates -I/usr/include -I. -I.
-DHAVE_CONFIG_H  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=pentium4
-fasynchronous-unwind-tables -o int_poly.o
int_poly.cc: In member function 'virtual bool
InternalPoly::divremsamet(InternalCF*, InternalCF*&, InternalCF*&)':
int_poly.cc:579: error: '::divremt' has not been declared
int_poly.cc: In member function 'virtual bool
InternalPoly::divremcoefft(InternalCF*, InternalCF*&, InternalCF*&, bool)':
int_poly.cc:1100: error: '::divremt' has not been declared
make: *** [int_poly.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.74085 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.74085 (%build)

Full build.log on request.
Comment 1 Rex Dieter 2006-02-12 14:17:08 EST
I know:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/3991-factory-2.0.5-6.fc5.1/

But thanks for documenting it.  (-:
Comment 2 Rex Dieter 2006-03-30 11:53:50 EST
Caused by libfac issue, which is now fixed, thanks to patch from bug #183258.

Note You need to log in before you can comment on or make changes to this bug.