Bug 1793024 - Calligra fails to build on ppc64le
Summary: Calligra fails to build on ppc64le
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: calligra
Version: rawhide
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F32BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2020-01-20 14:10 UTC by Marek Kašík
Modified: 2020-01-22 11:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-22 11:16:01 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Marek Kašík 2020-01-20 14:10:11 UTC
Description of problem:
I've rebased poppler at rawhide to 0.84.0 and tried to rebuild Calligra because of that but it failed on ppc64le. You can see logs here:

https://koji.fedoraproject.org/koji/taskinfo?taskID=40654399

Here is the first error:

In file included from /builddir/build/BUILD/calligra-3.1.0/filters/sheets/excel/import/ExcelImport.cpp:1443:
/builddir/build/BUILD/calligra-3.1.0/ppc64le-redhat-linux-gnu/filters/sheets/excel/import/calligra_filter_xls2ods_autogen/include/ExcelImport
.moc:58:15: error: 'Swinder::ExcelImportFactory' has not been declared
   58 | void Swinder::ExcelImportFactory::qt_static_metacall(QObject *_o, QMetaObject::Call _c, int _id, void **_a)
      |               ^~~~~~~~~~~~~~~~~~

Comment 1 Adam Williamson 2020-01-21 15:00:42 UTC
This breaks Rawhide composes, and so is automatically a Fedora 32 Beta blocking bug: "Bugs which entirely prevent the composition of one or more of the release-blocking images required to be built for a currently-pending (pre-)release" - https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers

Comment 2 Adam Williamson 2020-01-21 17:05:07 UTC
So I ran the build again, and this time it failed on aarch64, but passed on ppc64le. Different error, too :/ I'll look into it in a bit.

Comment 3 Adam Williamson 2020-01-21 20:18:47 UTC
Looks like the aarch64 failure was https://bugzilla.redhat.com/show_bug.cgi?id=1793471 . I'll try calligra once more after the new GCC build is done.

Comment 4 Adam Williamson 2020-01-22 11:16:01 UTC
Well, I got a build through. Didn't do anything to fix it, but it worked.


Note You need to log in before you can comment on or make changes to this bug.