Bug 1793251 - HAProxy network infra pods fail to listen on IPv6 addresses
Summary: HAProxy network infra pods fail to listen on IPv6 addresses
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Antoni Segura Puimedon
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On:
Blocks: 1793253
TreeView+ depends on / blocked
 
Reported: 2020-01-21 00:54 UTC by Antoni Segura Puimedon
Modified: 2020-05-04 11:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1793253 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:25:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1394 None closed HAProxy infra pod: Make v4/v6 compatible 2020-05-18 12:34:23 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:26:15 UTC

Description Antoni Segura Puimedon 2020-01-21 00:54:23 UTC
Description of problem:
The frontend and health check url were listening only on IPv4 for all interfaces when they should have been listening for both, IPv4 and IPv6.

Version-Release number of selected component (if applicable):4.4


How reproducible: 100%


Steps to Reproduce:
1. Deploy OpenShift on IPv6
2. crictl ps -a

Actual results: 
See that the pods are crashing


Expected results:
The pods are in running state and reply to the health checks on IPv6


Additional info:

Comment 2 Russell Bryant 2020-01-28 21:59:56 UTC
I tested this successfully.

Comment 4 errata-xmlrpc 2020-05-04 11:25:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.