Bug 1793253 - HAProxy network infra pods fail to listen on IPv6 addresses
Summary: HAProxy network infra pods fail to listen on IPv6 addresses
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Antoni Segura Puimedon
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On: 1793251
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-21 01:09 UTC by Antoni Segura Puimedon
Modified: 2020-02-19 05:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1793251
Environment:
Last Closed: 2020-02-19 05:39:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1399 None closed Bug 1793253: [release-4.3] HAProxy infra pod: Make v4/v6 compatible 2020-02-13 20:58:44 UTC
Red Hat Product Errata RHBA-2020:0492 None None None 2020-02-19 05:40:06 UTC

Description Antoni Segura Puimedon 2020-01-21 01:09:53 UTC
+++ This bug was initially created as a clone of Bug #1793251 +++

Description of problem:
The frontend and health check url were listening only on IPv4 for all interfaces when they should have been listening for both, IPv4 and IPv6.

Version-Release number of selected component (if applicable):4.3


How reproducible: 100%


Steps to Reproduce:
1. Deploy OpenShift on IPv6
2. crictl ps -a

Actual results: 
See that the pods are crashing


Expected results:
The pods are in running state and reply to the health checks on IPv6


Additional info:

Comment 2 Victor Voronkov 2020-02-06 11:44:51 UTC
Verified on 4.3.0-0.nightly-2020-02-03-115336-ipv6.1

Pods are running
oc served via API_VIP via HAProxy

oc get pods -n openshift-kni-infra -o wide | grep haproxy
haproxy-master-0.ocp-edge-cluster.qe.lab.redhat.com          2/2     Running   6          20h   fd2e:6f44:5dd8:c956::121   master-0.ocp-edge-cluster.qe.lab.redhat.com   <none>           <none>
haproxy-master-1.ocp-edge-cluster.qe.lab.redhat.com          2/2     Running   0          20h   fd2e:6f44:5dd8:c956::103   master-1.ocp-edge-cluster.qe.lab.redhat.com   <none>           <none>
haproxy-master-2.ocp-edge-cluster.qe.lab.redhat.com          2/2     Running   6          20h   fd2e:6f44:5dd8:c956::13a   master-2.ocp-edge-cluster.qe.lab.redhat.com   <none>           <none>

Comment 4 errata-xmlrpc 2020-02-19 05:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0492


Note You need to log in before you can comment on or make changes to this bug.