Bug 1794272 - docker-compose fails to build and install: python-dockerpty was retired
Summary: docker-compose fails to build and install: python-dockerpty was retired
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: docker-compose
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Hampton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS F32FailsToInstall PYTHON39 F33FTBFS
TreeView+ depends on / blocked
 
Reported: 2020-01-23 07:21 UTC by Miro Hrončok
Modified: 2020-04-01 16:32 UTC (History)
3 users (show)

Fixed In Version: docker-compose-1.25.4-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-01 00:17:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-01-23 07:21:26 UTC
python-dockerpty was retired:

https://src.fedoraproject.org/rpms/python-dockerpty/c/dd268096475c4e4bde6a49f94575a4bfa72ca02e?branch=master


Once the compose finishes and mirrors are synchronized, docker-compose will fail to build from source and fail to install as it requires python3-dockerpty on both buildtime and runtime.

Comment 1 Ben Cotton 2020-02-11 17:26:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 2 Fedora Release Engineering 2020-02-16 04:31:08 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 3 Michael Hampton 2020-02-29 18:49:33 UTC
*** Bug 1808669 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2020-03-04 23:35:05 UTC
This now blocks upgrades to Fedora 32:

> Error:
>   Problem 1: problem with installed package docker-compose-1.25.4-1.fc31.noarch
>    - docker-compose-1.25.4-1.fc31.noarch does not belong to a distupgrade repository
>    - nothing provides python3.8dist(dockerpty) >= 0.4.1 needed by docker-compose-1.24.1-3.fc32.noarch

Comment 5 Fedora Update System 2020-03-23 21:32:59 UTC
FEDORA-2020-0c8bfe47e7 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-0c8bfe47e7

Comment 6 Fedora Update System 2020-03-24 01:52:48 UTC
FEDORA-2020-0c8bfe47e7 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-0c8bfe47e7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-0c8bfe47e7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-04-01 00:17:50 UTC
FEDORA-2020-0c8bfe47e7 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-04-01 16:32:39 UTC
FEDORA-2020-0c8bfe47e7 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.