Bug 1808669 - docker-compose fails to build in Fedora rawhide: cd: docker-compose-1.25.4: No such file or directory
Summary: docker-compose fails to build in Fedora rawhide: cd: docker-compose-1.25.4: N...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: docker-compose
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Hampton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F33FTBFS
TreeView+ depends on / blocked
 
Reported: 2020-02-29 10:10 UTC by Miro Hrončok
Modified: 2020-03-23 21:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-23 21:42:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-02-29 10:10:22 UTC
docker-compose fails to build in Fedora rawhide:

+ cd docker-compose-1.25.4
/var/tmp/rpm-tmp.vICxtv: line 39: cd: docker-compose-1.25.4: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.vICxtv (%prep)
    Bad exit status from /var/tmp/rpm-tmp.vICxtv (%prep)

It seems like the update was pushed without even testing if it preps.

This blocks the Python 3.9 rebuild of docker-compose.

For the build logs with Python 3.9, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01260065-docker-compose/

For all our attempts to build docker-compose with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/docker-compose/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Michael Hampton 2020-02-29 18:49:33 UTC

*** This bug has been marked as a duplicate of bug 1794272 ***

Comment 2 Miro Hrončok 2020-02-29 19:47:41 UTC
This one is not related to dockerpty.

Comment 3 Michael Hampton 2020-03-23 21:17:08 UTC
Closed as duplicate in error. I'll be taking care of this shortly.

Comment 4 Michael Hampton 2020-03-23 21:42:51 UTC
This is now built successfully in rawhide.


Note You need to log in before you can comment on or make changes to this bug.