Bug 1794548 - Console and console operator should support IPv6 [openshift-4.3] [NEEDINFO]
Summary: Console and console operator should support IPv6 [openshift-4.3]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.z
Assignee: bpeterse
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1788164 (view as bug list)
Depends On: 1794546 1796618
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-23 19:42 UTC by bpeterse
Modified: 2020-02-19 05:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1794546
Environment:
Last Closed: 2020-02-19 05:39:53 UTC
Target Upstream Version:
hasha: needinfo? (bpeterse)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 376 None closed Bug 1794548: IPv6 support to console operator & console [openshift-4.3.z] 2020-03-09 02:38:57 UTC
Red Hat Product Errata RHBA-2020:0492 None None None 2020-02-19 05:40:06 UTC

Description bpeterse 2020-01-23 19:42:09 UTC
+++ This bug was initially created as a clone of Bug #1794546 +++

Description of problem:

Console, downloads deployment, and console operator will not run on an IPv6 cluster.  Some configurations need updating to support IPv6.

Comment 1 bpeterse 2020-01-23 19:44:50 UTC
https://github.com/openshift/console-operator/pull/375 opened for 4.4, cherry-pick/backport coming once merged.

Comment 2 bpeterse 2020-01-30 02:00:07 UTC
*** Bug 1788164 has been marked as a duplicate of this bug. ***

Comment 6 Dan Winship 2020-02-07 14:25:26 UTC
Assigning all 4.3.z IPv6 bugs to Marius Cornea for QA, as they are not yet QA-able in stock release-4.3 builds.

Comment 7 Marius Cornea 2020-02-11 21:43:06 UTC
Verified on 4.3.0-0.nightly-2020-02-10-055634(included in 4.3.0-0.nightly-2020-02-10-055634-ipv6.3) on a bare metal deployment

Image used in local disconnected registry:
[kni@provisionhost-0 ~]$ oc adm release info --image-for=console-operator  -a ~/combined-secret.json   registry.ocp-edge-cluster.qe.lab.redhat.com:5000/localimages/local-release-image:4.3.0-0.nightly-2020-02-10-055634-ipv6.3
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:ccf1987499cbbf5aadd585620cfbd34269137112d03bd44082523729cfe76851

Image used in 4.3.0-0.nightly-2020-02-10-055634

[kni@provisionhost-0 ~]$ oc adm release info --image-for=console-operator  -a ~/combined-secret.json   registry.svc.ci.openshift.org/ocp/release:4.3.0-0.nightly-2020-02-10-055634
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:ccf1987499cbbf5aadd585620cfbd34269137112d03bd44082523729cfe76851

[kni@provisionhost-0 ~]$ oc get po -n openshift-console
NAME                         READY   STATUS    RESTARTS   AGE
console-67c8fc4ccb-9trf6     1/1     Running   1          87m
console-67c8fc4ccb-sdpt4     1/1     Running   0          82m
downloads-7b794869b6-7vv98   1/1     Running   0          89m
downloads-7b794869b6-vwrtz   1/1     Running   0          89m
[kni@provisionhost-0 ~]$ oc get po -n openshift-console-operator
NAME                                READY   STATUS    RESTARTS   AGE
console-operator-84bdbcb596-gjk5v   1/1     Running   0          88m
[kni@provisionhost-0 ~]$ oc get co/console
NAME      VERSION                                    AVAILABLE   PROGRESSING   DEGRADED   SINCE
console   4.3.0-0.nightly-2020-02-10-055634-ipv6.3   True        False         False      81m

Comment 9 errata-xmlrpc 2020-02-19 05:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0492


Note You need to log in before you can comment on or make changes to this bug.