Bug 1794606 - `oc rsh` fails with "error: remote shell for deployments.apps is not supported"
Summary: `oc rsh` fails with "error: remote shell for deployments.apps is not supported"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Maciej Szulik
QA Contact: Mike Fiedler
URL:
Whiteboard:
Depends On:
Blocks: 1802262
TreeView+ depends on / blocked
 
Reported: 2020-01-24 01:21 UTC by Miciah Dashiel Butler Masters
Modified: 2020-05-04 11:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1802262 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:26:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 260 None closed Bug 1794606: Use polymorphic helpers from exec, when reading a pod 2020-10-09 10:32:35 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:27:08 UTC

Description Miciah Dashiel Butler Masters 2020-01-24 01:21:05 UTC
Description of problem:

When I try to use `oc rsh` to open a shell to a deployment, it fails and prints "error: remote shell for deployments.apps is not supported".


Version-Release number of selected component (if applicable):

The failure can be reproduced on both 4.4.0-0.ci-2020-01-21-134224 and 4.4.0-0.ci-2020-01-23-204118.


How reproducible:

Consistently.


Steps to Reproduce:
1. Launch a 4.4 cluster.
2. Run `oc -n openshift-ingress rsh deploy/router-default`.


Actual results:

The `oc rsh` command fails on 4.4:

    % oc adm release extract --command=oc registry.svc.ci.openshift.org/ocp/release:4.4.0-0.ci-2020-01-23-204118
    oc adm release extract --command=oc   1.51s user 1.38s system 18% cpu 15.415 total
    % ./oc version
    Client Version: v4.2.0-alpha.0-386-g2dc71a4
    Server Version: 4.4.0-0.ci-2020-01-23-204118
    Kubernetes Version: v1.17.1
    % ./oc -n openshift-ingress rsh deploy/router-default
    error: remote shell for deployments.apps is not supported
    zsh: exit 1     ./oc -n openshift-ingress rsh deploy/router-default
    % 


Expected results:

The `oc rsh` command should succeed, as it does on a 4.3 cluster:

    % oc adm release extract --command=oc registry.svc.ci.openshift.org/ocp/release:4.3.0-0.ci-2020-01-21-121240
    oc adm release extract --command=oc   1.30s user 1.17s system 13% cpu 18.392 total
    % ./oc version
    Client Version: v4.2.0-alpha.0-295-g6a937df
    Server Version: 4.3.0-0.ci-2020-01-21-121240
    Kubernetes Version: v1.16.2
    % ./oc -n openshift-ingress rsh deploy/router-default
    sh-4.2$

Comment 2 Mike Fiedler 2020-01-31 20:45:51 UTC
Verified - oc rsh to deployment works fine:

[root@ip-172-31-53-199 tmp]# oc version
Client Version: 4.4.0-0.nightly-2020-01-31-190444
Server Version: 4.4.0-0.nightly-2020-01-31-190444
Kubernetes Version: v1.17.1


[root@ip-172-31-53-199 tmp]# oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-01-31-190444   True        False         2m39s   Cluster version is 4.4.0-0.nightly-2020-01-31-190444

[root@ip-172-31-53-199 tmp]# oc -n openshift-ingress rsh deploy/router-default
sh-4.2$

Comment 4 errata-xmlrpc 2020-05-04 11:26:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.