Bug 1802262 - `oc rsh` fails with "error: remote shell for deployments.apps is not supported"
Summary: `oc rsh` fails with "error: remote shell for deployments.apps is not supported"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1794606
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-12 18:10 UTC by Maciej Szulik
Modified: 2020-04-08 07:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1794606
Environment:
Last Closed: 2020-04-08 07:39:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 294 0 None closed Bug 1802262: Use polymorphic helpers from exec, when reading a pod 2020-04-08 08:14:53 UTC
Github openshift origin pull 24660 0 None closed Bug 1802262: Loosen help tests for oc rsh 2020-04-08 08:14:53 UTC
Red Hat Product Errata RHBA-2020:1262 0 None None None 2020-04-08 07:40:03 UTC

Comment 1 Maciej Szulik 2020-02-12 18:12:54 UTC
The problem is that in 4.4 we're not serving extensions.Deployment so to reproduce this problem 
you need to use 4.3 oc against 4.4 cluster, with this fix 4.3 binary should work w/o problems.

Comment 4 zhou ying 2020-03-30 08:13:52 UTC
[root@dhcp-140-138 ~]# oc -n openshift-ingress rsh deploy/router-default
sh-4.2$ exit
exit
[root@dhcp-140-138 ~]# oc version -o yaml 
clientVersion:
  buildDate: "2020-03-28T08:12:50Z"
  compiler: gc
  gitCommit: 6a90d0a59b25a70c36a68ea00873f96fb6db0ef4
  gitTreeState: clean
  gitVersion: openshift-clients-4.3.10-202003280552
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64

Comment 6 errata-xmlrpc 2020-04-08 07:39:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1262


Note You need to log in before you can comment on or make changes to this bug.