Bug 179475 - kdump service fails to start
kdump service fails to start
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Don Zickus
: 182688 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-01-31 12:37 EST by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-21 14:03:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2006-01-31 12:37:15 EST
Description of problem:
I tried to follow the instructions at
http://fedoranews.org/mediawiki/index.php/Using_Kexec_and_Kdump_in_Rawhide for
using kdump to debug kernel crashes.  However after installing kexec-tools, the
kdump service fails to start giving this message:

  Invalid memory segment 0x1000000 - 0x1242fff

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install kexec-tools
2. start kdump service
Actual results:
kdump service doesn't start

Expected results:
kdump starts

Additional info:
Comment 1 Ellen Shull 2006-02-05 03:40:18 EST
Almost same error here, but with slightly newer build of kexec-tools.  I get:

Invalid memory segment 0x1000000 - 0x1240fff

Version-Release number of selected component (if applicable):

Additional info:
System is fairly fresh, installed from FC5T2 and updated to current rawhide.

Kernel is not tainted.

$ cat /etc/sysconfig/kdump
# Kernel Version string for the -kdump kernel, such as 2.6.13-1544.FC5kdump
# If no version is specified, then the init script will try to find a
# kdump kernel with the same version number as the running kernel.

# The kdump commandline is the command line that needs to be passed off to
# the kdump kernel.  This will likely match the contents of the grub kernel
# line.  For example:
# If a command line is not specified, the default will be taken from
# /proc/cmdline

# Any additional kexec arguments required.  In most situations, this should
# be left empty

$ cat /proc/cmdline
ro root=LABEL=/1

$ uname -a
Linux ip70-171-208-137.tc.ph.cox.net 2.6.15-1.1907_FC5 #1 Fri Feb 3 23:23:13 EST
2006 i686 athlon i386 GNU/Linux
Comment 2 Alexandre Oliva 2006-02-23 20:54:20 EST
*** Bug 182688 has been marked as a duplicate of this bug. ***
Comment 3 Don Zickus 2006-03-13 13:48:55 EST
The documentation is unfortunately a little dated.  Please add the kernel
parameter "crashkernel =64M@16M" to your /etc/grub.conf file in the kernel you
are using as shown in the example below:

kernel /vmlinuz-2.6.15-1.2039_FC5 ro root=LABEL=/ crashkernel=64M@16M

Then reboot your machine.  This parameter tells the kernel to reserve 64MB of
memory at physical location 16MB.  The kdump kernel is placed here upon
completion of the kdump init script.  

Also please update your kexec_tools package (yum update kexec_tools).  A few
bugs fixes have been added to make this process easier.  

Let me know if this solves your problem.
Comment 4 Jarod Wilson 2006-08-21 14:03:05 EDT
We could definitely use a kdump howto. :)

/me ponders writing one up to put in the Fedora wiki...

Note You need to log in before you can comment on or make changes to this bug.