Bug 1794813 - [buildcop] release-openshift-origin-installer-e2e-aws-upgrade-4.1-stable-to-4.1-nightly failing on: error waiting for deployment \"dp\" to match expectation
Summary: [buildcop] release-openshift-origin-installer-e2e-aws-upgrade-4.1-stable-to-4...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
: 1788324 (view as bug list)
Depends On: 1796017
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-24 18:28 UTC by Cesar Wong
Modified: 2020-02-24 16:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1796017 (view as bug list)
Environment:
Last Closed: 2020-02-24 16:52:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24474 0 None closed Bug 1794813: UPSTREAM: 79160: e2e Flake: Pass updated deployment for comparison of replica count 2020-02-14 14:15:03 UTC
Red Hat Product Errata RHBA-2020:0460 0 None None None 2020-02-24 16:52:59 UTC

Description Cesar Wong 2020-01-24 18:28:25 UTC
Description of problem:

e2e upgrade test fails for release 4.1 on

fail [k8s.io/kubernetes/test/e2e/upgrades/apps/deployments.go:166]: Expected error:
    <*errors.errorString | 0xc0003fbf30>: {
        s: "error waiting for deployment \"dp\" status to match expectation: deployment status: v1.DeploymentStatus{ObservedGeneration:3, Replicas:2, UpdatedReplicas:2, ReadyReplicas:2, AvailableReplicas:2, UnavailableReplicas:0, Conditions:[]v1.DeploymentCondition{v1.DeploymentCondition{Type:\"Progressing\", Status:\"True\", LastUpdateTime:v1.Time{Time:time.Time{wall:0x0, ext:63715480704, loc:(*time.Location)(0x90bdf20)}}, LastTransitionTime:v1.Time{Time:time.Time{wall:0x0, ext:63715480680, loc:(*time.Location)(0x90bdf20)}}, Reason:\"NewReplicaSetAvailable\", Message:\"ReplicaSet \\\"dp-57cc5d77b4\\\" has successfully progressed.\"}, v1.DeploymentCondition{Type:\"Available\", Status:\"True\", LastUpdateTime:v1.Time{Time:time.Time{wall:0x0, ext:63715482612, loc:(*time.Location)(0x90bdf20)}}, LastTransitionTime:v1.Time{Time:time.Time{wall:0x0, ext:63715482612, loc:(*time.Location)(0x90bdf20)}}, Reason:\"MinimumReplicasAvailable\", Message:\"Deployment has minimum availability.\"}}, CollisionCount:(*int32)(nil)}",
    }
   error waiting for deployment "dp" status to match expectation: deployment status: v1.DeploymentStatus{ObservedGeneration:3, Replicas:2, UpdatedReplicas:2, ReadyReplicas:2, AvailableReplicas:2, UnavailableReplicas:0, Conditions:[]v1.DeploymentCondition{v1.DeploymentCondition{Type:"Progressing", Status:"True", LastUpdateTime:v1.Time{Time:time.Time{wall:0x0, ext:63715480704, loc:(*time.Location)(0x90bdf20)}}, LastTransitionTime:v1.Time{Time:time.Time{wall:0x0, ext:63715480680, loc:(*time.Location)(0x90bdf20)}}, Reason:"NewReplicaSetAvailable", Message:"ReplicaSet \"dp-57cc5d77b4\" has successfully progressed."}, v1.DeploymentCondition{Type:"Available", Status:"True", LastUpdateTime:v1.Time{Time:time.Time{wall:0x0, ext:63715482612, loc:(*time.Location)(0x90bdf20)}}, LastTransitionTime:v1.Time{Time:time.Time{wall:0x0, ext:63715482612, loc:(*time.Location)(0x90bdf20)}}, Reason:"MinimumReplicasAvailable", Message:"Deployment has minimum availability."}}, CollisionCount:(*int32)(nil)}
not to have occurred

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-upgrade-4.1-stable-to-4.1-nightly/9

Version-Release number of selected component (if applicable):
4.1.z

How reproducible:
e2e upgrade test failure

Steps to Reproduce:
Run release-openshift-origin-installer-e2e-aws-upgrade-4.1-stable-to-4.1-nightly test

Actual results:
test fails

Expected results:
test passes

Additional info:

Comment 1 Maciej Szulik 2020-01-29 12:16:44 UTC
Fix in https://github.com/openshift/origin/pull/24474

Comment 3 Tomáš Nožička 2020-02-04 15:12:54 UTC
*** Bug 1788324 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2020-02-24 16:52:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0460


Note You need to log in before you can comment on or make changes to this bug.