Bug 179482 - Unable to write to DVD+R dual layer
Unable to write to DVD+R dual layer
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-01-31 13:57 EST by Andy Burns
Modified: 2015-01-04 17:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-19 23:41:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
debug log from k3b (397.70 KB, text/plain)
2006-01-31 13:57 EST, Andy Burns
no flags Details

  None (edit)
Description Andy Burns 2006-01-31 13:57:22 EST
Description of problem:

Trying to backup laptop to DVD, the file was created under windows and written
to Linux over samba, initially it was one huge file >6GB which k3b refused as it
declined files over 4GB, so I split it into multiple files each 1GB, then k3b
was happy to allow me to build a data DVD project.

Inserted a blank DVD+R dual layer disk, under diskinfo k3b recognised it as
such, went to burn, had errors something like unable to set speed from 2770(?)
to 3554(?), I tried a few combinations of
AUTO/DAO/speed=ignore/speed=auto/speed=1 but no joy.

The closest I got was to disable "on the fly", it then created the image file
and was about to burn it, but got an error related to Dual Layer, debug log

Version-Release number of selected component (if applicable):

Name   : k3b
Arch   : x86_64
Version: 0.12.10
Release: 2

How reproducible:

Twice so far 

Steps to Reproduce:
1. burn DVD+RDL without on the fly
Actual results:

write fails, fortunately it leaves the disk untouched, so doesn't make expensive
coasters :-)

Expected results:

Able to burn dual layer (either with or without on the fly)

Additional info:

Drive is a Samsung TS-H552B (using latest firmware I am aware of TS11 from
November 2005) as the only device on PATA controller, media is Infiniti branded

Using FC5T2 I have burnt several DVD-RW, CD-RW and CD-R successfuly 
on this drive and on a LITE-ON LDW-411S, can't try this with the other drive as
it isn't DL (and I'm not going to touch the hacked firmware that claims to
"upgrade" the drive)
Comment 1 Andy Burns 2006-01-31 13:57:22 EST
Created attachment 123932 [details]
debug log from k3b
Comment 2 Harald Hoyer 2006-02-01 03:18:27 EST
Executing 'builtin_dd if=/tmp/kde-root/k3b_image.img of=/dev/hda obs=32k seek=0'
/dev/hda: splitting layers at 1843520 blocks

Just to make sure, this isn't a permission problem, could you please try this as
"root"? :)
Comment 3 Andy Burns 2006-02-01 03:43:23 EST
Sorry I should have mentioned initially, this was as root
Comment 4 Harald Hoyer 2006-02-01 03:59:29 EST
hmm, nothing I can do here, other than to assign this to the kernel, as
growisofs seems to get a -EIO from the ioctl.
Comment 5 Andy Burns 2006-02-03 07:24:39 EST
Added harald back to cc: just as a FYI, please feel free to remove yourself again.

OK, since this has now been thown over to kernel I've tested it again with

In the process of testing I found that the first error I got "Failed to change
write speed: 2770->3324" doesn't happen if I set speed=ignore, it happens if k3b
tries to set -speed=2.4

Anyway, the second error seems like it might be related to my burner, not kernel
I put in a blank DVD+RDL media, dmesg at this stage only shows

"cdrom: This disc doesn't have any tracks I recognize!" 

which is ok, k3b sees the blank media properly so I start to burn it, the drive
makes some slightly unhealthy sounding seek noises, followed by some even worse
sounding noises, at this stage k3b gives the


message and from dmesg I see

"hda: irq timeout: status=0xd0 { Busy }
ide: failed opcode was: unknown
hda: ATAPI reset complete"

at this point the drive spins up to maximum revs, I can feel the wind coming
from it, it doesn't slow down by itself, I have to eject the media, afterwards
the drive *will* recognise another CD inserted, so the reset seems to have
worked.The EIO doesn't look like a kernel problem, just the kernel reporting the
bad news from the drive to k3b :-(

I've tried another blank DVD+RDL media in case the first one is faulty.

This sounds more likely to be a drive firmware issue than a kernel problem to
me, I am using the latest firmware for the drive, I suppose I could try an older
firmware, I have never attempted to burn a dual layer with this drive (linux or
windows) before, but it has been OK on single layer.

Is it likely to be a dead end for this bug? change it to NOTABUG?
Comment 6 Andy Burns 2006-02-04 04:09:35 EST
Err, did you "NEEDINFO" this one when you assigned it Dave? If so what info? I'm
included to think its a hardware issue 

/me ponders buying 3rd DVD+-R/RW drive :-(

Comment 7 Pavel Polischouk 2006-10-06 09:51:09 EDT
I had this bug on my DVD writer. After upgrading the drive firmware, the same
drive was able to burn the same +R9 disc correctly.

Most likely hardware (firmware) issue, the drive might refuse to write DVD+-R9
if it doesn't recognize the media as dual layer, drive manufacturers usually do
a good job releasing new firmwares that recognize the newer media.

I used the latest cdrecord- (from FC5/updates/testing)to
successfully write the disc, I didn't try k3b or growisofs.
Comment 8 Dave Jones 2006-10-16 15:17:54 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 9 Jon Stanley 2008-01-19 23:41:00 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.