Bug 1795456 - [Events page] "Custom Resource" events only show up in "All Resources" type view [openshift-4.4]
Summary: [Events page] "Custom Resource" events only show up in "All Resources" type v...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1786325 (view as bug list)
Depends On:
Blocks: 1796461 1796523
TreeView+ depends on / blocked
 
Reported: 2020-01-28 02:00 UTC by tony.wu
Modified: 2020-05-20 12:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1796461 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:27:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
1_[Events]__All-Resources-view___show_appsodyapplication_events.png (650.17 KB, image/png)
2020-01-28 02:00 UTC, tony.wu
no flags Details
2_[Events]__AppsodyApplication-CR-view___no_events.png (266.32 KB, image/png)
2020-01-28 02:02 UTC, tony.wu
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4112 0 None closed Bug 1795456: Fix bug where resource filter is broken for GroupVersionKind resources 2020-05-20 12:13:36 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:27:50 UTC

Description tony.wu 2020-01-28 02:00:08 UTC
Created attachment 1655846 [details]
1_[Events]__All-Resources-view___show_appsodyapplication_events.png

Description of problem:

It's noticed when looking at "Events" from Custom Resources, they only show up when "Resource" dropdown is set as "All Resources" on the "Events" view.

If change "Resource" dropdown to filter that Custom Resource only, you can only get an empty event list.

Please see the attached screenshots for reference:
* "*Events*" view - "*All Resources*" 
    --> You can see Events from “AppsodyApplication” CR
    1_[Events]__All-Resources-view___show_appsodyapplication_events.png

* "*Events*" view -  filter by "*AppsodyApplication*" CR
    --> "No matching events"
    2_[Events]__AppsodyApplication-CR-view___no_events.png


Version-Release number of selected component (if applicable):
OCP 4.3 and 4.4

How reproducible:
Always


Steps to Reproduce:
1. Create a Custom Resource
2. Go to "Events" page - with "Resource" dropdown set as "All Types" 
   --> make sure see the Events from the Custom Resource
3. Change "Resource" dropdown as that particular Custom Resource
   --> empty event list

Actual results:
Empty event list.

Expected results:
Events filtered by selected CR.


Additional info:

Comment 1 tony.wu 2020-01-28 02:02:20 UTC
Created attachment 1655847 [details]
2_[Events]__AppsodyApplication-CR-view___no_events.png

Comment 2 tony.wu 2020-01-28 02:03:08 UTC
Ported from JIRA:
https://issues.redhat.com/browse/CONSOLE-2047

Comment 4 Yadan Pei 2020-02-03 08:25:17 UTC
1. cluster admin installs 'etcd Operator' into one namespace

2. Wait until operator is successfully subscribed
$ oc get csv -n testuser5-1
NAME                                     DISPLAY                        VERSION   REPLACES   PHASE
akka-cluster-operator-certified.v0.2.0   Akka Cluster Operator          0.2.0                Succeeded
etcdoperator.v0.9.4                      etcd                           0.9.4                Succeeded

3. Create Custom Resource 'EtcdCluster' from Operator Hub

4. Check Custom Resource events via CLI
$ oc describe etcdcluster example  -n testuser5-1
Name:         example
Namespace:    testuser5-1
Labels:       <none>
Annotations:  <none>
API Version:  etcd.database.coreos.com/v1beta2
Kind:         EtcdCluster
Metadata:
  Creation Timestamp:  2020-02-03T07:59:27Z

......
Events:
  Type    Reason            Age   From                            Message
  ----    ------            ----  ----                            -------
  Normal  New Member Added  104s  etcd-operator-7c74855bbf-nrvm2  New member example-5s5ccw4pgp added to cluster
  Normal  New Member Added  72s   etcd-operator-7c74855bbf-nrvm2  New member example-rk89d8xqbx added to cluster
  Normal  New Member Added  32s   etcd-operator-7c74855bbf-nrvm2  New member example-xp6bj75nzq added to cluster

5. Check at Events page Home -> Events, in Resource dropdown select 'EtcdCluster' it will show the same events as we get from CLI

I didn't get Custom Resource 'AppsodyApplication' successfully created so verified the fix on 'etcd' operator

Let me know if it's wrong. Verified on 4.4.0-0.nightly-2020-02-02-201619

Comment 6 errata-xmlrpc 2020-05-04 11:27:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581

Comment 7 Samuel Padgett 2020-05-20 12:16:44 UTC
*** Bug 1786325 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.