Bug 179600 - Fedora Core 4 fails to install kernel panic sis5513 error
Summary: Fedora Core 4 fails to install kernel panic sis5513 error
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 179603 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-01 16:45 UTC by Mohit Agarwal
Modified: 2015-01-04 22:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 01:26:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mohit Agarwal 2006-02-01 16:45:53 UTC
Description of problem:

Installing Fedora Core 4 on a ASUS K8S MX motherboard results in kernel 
panic. Happens before anaconda comes into play. 
I thought the error was perhaps related to the sis5513 ide controller. 
So, tried 'linux ide=nodma' and 'linux noprobe' with no change in error.

Error: 
SIS_IDE probe of 000:00:02.5 failed with error -1. 

A little later, these errors appear:

Could not open root device "<NULL>" or unknown block(8,3)
Please append a correct root =  boot option
Kernel Panic - not syncing 
VFS: Unable to mount root fs on unknown block (8,3) 

Version-Release number of selected component (if applicable):
Fedora Core 4 

How reproducible:
Always

Steps to Reproduce:
1. Get a ASUS K8S MX board
2. Boot from FC4 CD 
3. start installation
4. Kernel panic before anaconda. 
  
Actual results:
The  install process stops. 

Expected results:
Anaconda shud have started

Additional info:
The install of Fedora Core 3 works fine. 
linux ide=nodma or linux noprobe doesnt help.

Comment 1 Jeremy Katz 2006-02-01 17:09:30 UTC
*** Bug 179603 has been marked as a duplicate of this bug. ***

Comment 2 Dave Jones 2006-02-03 01:26:10 UTC
I don't think there's anything we can really do to make FC4 work on this without
recreating the ISOs with a new kernel (Ie, try the community FC4.2 respins maybe?).

It'd be useful if you could test FC5test on this box to make sure that when FC5
is released it doesn't have the same problem.



Note You need to log in before you can comment on or make changes to this bug.