Bug 179604 - Xen hypervisor parameters are not copied during kernel installation
Xen hypervisor parameters are not copied during kernel installation
Status: CLOSED DUPLICATE of bug 181478
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks: 179599
  Show dependency treegraph
 
Reported: 2006-02-01 11:54 EST by James Morris
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 13:38:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Morris 2006-02-01 11:54:02 EST
Description of problem:

When you install a new kernel-xen-hypervisor package, the hypervisor parameters
are not copied from previous grub entries, as they are for the kernel itself.

Version-Release number of selected component (if applicable):


mkinitrd-5.0.17-1

How reproducible:

Always

Steps to Reproduce:
1. install a new kernel-xen-hypervisor
2.
3.
  
Actual results:

title Fedora Core (2.6.15-1.35_FC5hypervisor)
        root (hd0,0)
        kernel /xen.gz-2.6.15-1.35_FC5
        module /vmlinuz-2.6.15-1.35_FC5hypervisor ro
root=/dev/VolGroup00/LogVol00 console=ttyS0,115200 
        module /initrd-2.6.15-1.35_FC5hypervisor.img


Expected results:


title Fedora Core (2.6.15-1.35_FC5hypervisor)
        root (hd0,0)
        kernel /xen.gz-2.6.15-1.35_FC5 com1=115200,8n1 console=com1 sync_console
        module /vmlinuz-2.6.15-1.35_FC5hypervisor ro
root=/dev/VolGroup00/LogVol00 console=ttyS0,115200 
        module /initrd-2.6.15-1.35_FC5hypervisor.img

Additional info:
Comment 1 Rahul Sundaram 2006-02-20 05:38:31 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Jeremy Katz 2006-02-24 13:38:30 EST

*** This bug has been marked as a duplicate of 181478 ***

Note You need to log in before you can comment on or make changes to this bug.