Bug 181478 - Hypervisor options are not copied to new kernels
Hypervisor options are not copied to new kernels
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
: 179604 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-14 11:10 EST by Juan Quintela
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 14:06:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Quintela 2006-02-14 11:10:03 EST
Description of problem:

hypervisor options are not copied from one kernel to the other

Version-Release number of selected component (if applicable):
All releases.

How reproducible:

Allways happens

Steps to Reproduce:
1. Install a xen hypervisor kernel
2. Change the xen line optinos (notice that the kernel options are copied as
expected)
3. Install a nex xen hypervisor kernel
   
Actual results:

Hypervisor options are not copied.
Kekernel options are copied.

Expected results:

Both hypervisor & kernel optinos are copied from previous entry.

Additional info:
Comment 1 Rahul Sundaram 2006-02-20 05:43:25 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Jeremy Katz 2006-02-24 13:38:44 EST
*** Bug 179604 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2006-02-24 14:06:42 EST
Actually getting around to testing this, the right thing does happen if you set
your hypervisor kernel as the default.  In that case, both the kernel options
and the hypervisor options are getting copied correctly.

Note You need to log in before you can comment on or make changes to this bug.