Bug 179606 - Symbol MixAudio16_MMX_9 will not found at x86_64 plattform when start blender.
Symbol MixAudio16_MMX_9 will not found at x86_64 plattform when start blender.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openal (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 180018 (view as bug list)
Depends On:
Blocks: 179568
  Show dependency treegraph
 
Reported: 2006-02-01 11:56 EST by Jochen Schmitt
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-25 06:25:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2006-02-01 11:56:37 EST
Description of problem:

When a user start blender on a x86_64 system the symbol Mixaudio16_MMX_9 will
not found in /usr/lib64/libopenal.so.0.

Version-Release number of selected component (if applicable):

blender-2.41-1
openal-0.0.8-2

How reproducible:

start blender.
  
Additional info:

readelf libopenal.so.0 produced:

    14: 0000000000020305    44 FUNC    GLOBAL DEFAULT   10 alcCloseDevice
    15: 000000000001d6d2   344 FUNC    GLOBAL DEFAULT   10 esd_blitbuffer
    16: 0000000000014507   161 FUNC    GLOBAL DEFAULT   10 _alExit
    17: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND MixAudio16_MMX_9
    18: 000000000000f09f    69 FUNC    GLOBAL DEFAULT   10 alGetBuffer3i
    19: 00000000001325e0     1 OBJECT  GLOBAL DEFAULT   23 time_for_mixer_to_die
    20: 000000000000f7a4    40 FUNC    GLOBAL DEFAULT   10 alBufferfv

Best Regards: Jochen Schmitt
Comment 1 Andreas Bierfert 2006-02-04 08:06:29 EST
Ok here are a few pointers:
- I just pushed a new openal version for devel... please try again with this
one, it is from cvs and supposed to be better
- blender probably should require freealut-devel which was split from openal
some time ago (see #179988)

Please let me know the results...
Comment 2 Henrik Nordstrom 2006-02-04 14:44:24 EST
torcs is bitten by the same issue.
Comment 3 Henrik Nordstrom 2006-02-04 17:39:17 EST
*** Bug 180018 has been marked as a duplicate of this bug. ***
Comment 4 Henrik Nordstrom 2006-02-04 17:46:54 EST
downgrading to the previous openal version in extras works for me (i.e. torcs
starting fine)

downgraded to: openal-0.0-0.4.20040726.x86_64

didn't find a newer version in extras-development, but maybe it hasn't been
pushed out to the mirrors yet? The version I find in extras-development is
0.0.8-2.fc5 which I assume is a rebuild of 0.0.8-2.fc4 in extras..

Note: blender also starts fine here using the downgraded openal version.
Comment 5 Andreas Bierfert 2006-02-04 21:20:52 EST
new fc5 version (openal-0.0.9-0.2.20060204cvs) should hit mirrors soon... please
try again with this version and let me know if it works any better =) I don't
have a x86_64 to test this...

also important for blender: I have just imported and pushed freealut which
should be required by lender (BR: freealut-devel should be sufficient to pull in
openal-devel)
Comment 6 Jochen Schmitt 2006-02-05 15:19:41 EST
I have try to compile blender with opeal-0.0.9-0.2.20060204cvs.

I have got the following error messages:

intern/SoundSystem/openal/SND_OpenALDevice.cpp:48:21: error: AL/alut.h: No such
file or directory
intern/SoundSystem/openal/SND_OpenALDevice.cpp: In member function 'virtual SND_
WaveSlot* SND_OpenALDevice::LoadSample(const STR_String&, void*, int)':
intern/SoundSystem/openal/SND_OpenALDevice.cpp:433: error: 'alutLoadWAVMemory' w
as not declared in this scope
intern/SoundSystem/openal/SND_OpenALDevice.cpp:448: error: 'alutLoadWAVFile' was
 not declared in this scope
intern/SoundSystem/openal/SND_OpenALDevice.cpp:476: error: 'alutUnloadWAV' was n
ot declared in this scope
intern/SoundSystem/openal/SND_OpenALDevice.cpp: At global scope:
intern/SoundSystem/openal/SND_OpenALDevice.cpp:512: warning: unused parameter 'r
                                                                         
ollofffactor'
intern/SoundSystem/openal/SND_OpenALDevice.cpp:687: warning: unused parameter 'i
                                                                          d'
intern/SoundSystem/openal/SND_OpenALDevice.cpp:687: warning: unused parameter 'l
                                                                          oopstart'
intern/SoundSystem/openal/SND_OpenALDevice.cpp:687: warning: unused parameter 'l
                                                                          oopend'
intern/SoundSystem/openal/SND_OpenALDevice.cpp:739: warning: unused parameter 'o
                                                                         
rientation'
intern/SoundSystem/openal/SND_OpenALDevice.cpp:739: warning: unused parameter 'l
                                                                         
isposition'
scons: *** [/home/pclinux/cvs/fed-extras/blender/FC-4/build/linux2/intern/SoundS
                                                                         
ystem/openal/SND_OpenALDevice.o] Error 1
scons: building terminated because of errors.
Fehler: Bad exit status from /var/tmp/rpm-tmp.74414 (%build)

Best Regards:

Jochen Schmitt
Comment 7 Andreas Bierfert 2006-02-05 16:35:22 EST
[10:38 PM][awjb@alkaid ~]$ rpm -qf /usr/include/AL/alut.h
freealut-devel-1.0.0-1
Comment 8 Jochen Schmitt 2006-02-06 15:43:20 EST
When I try to compile blender if freealut installed; I got the following error
messages:

-lextern_qhull -lblender_python -lpython2.4 -lSDL -lpthread -lpng -ljpeg -lz
-lopenal -lm -lutil -lstdc++ -lGL -lGLU
/usr/lib/python2.4/config/libpython2.4.a(posixmodule.o): In function `posix_tmpnam':
: warning: the use of `tmpnam_r' is dangerous, better use `mkstemp'
/usr/lib/python2.4/config/libpython2.4.a(posixmodule.o): In function
`posix_tempnam':
: warning: the use of `tempnam' is dangerous, better use `mkstemp'
/home/pclinux/cvs/fed-extras/blender/FC-4/build/linux2/lib/libsoundsystem.a(SND_OpenALDevice.o):
In function `SND_OpenALDevice::LoadSample(STR_String const&, void*, int)':
SND_OpenALDevice.cpp:(.text+0x3f0): undefined reference to `alutLoadWAVMemory'
SND_OpenALDevice.cpp:(.text+0x459): undefined reference to `alutUnloadWAV'
SND_OpenALDevice.cpp:(.text+0x4a8): undefined reference to `alutLoadWAVFile'
collect2: ld returned 1 exit status
scons: *** [blender] Error 1
scons: building terminated because of errors.
Fehler: Bad exit status from /var/tmp/rpm-tmp.53158 (%build)


Best Regards:

Jochen Schmitt
Comment 9 Andreas Bierfert 2006-02-06 15:51:31 EST
I am sorry for you trouble with this... I will see what is causing this and get
back to you one I have a compiling version here...

Just one question: What arch is this on and what fc? Is the spec you are trying
to build commited to cvs?
Comment 10 Jochen Schmitt 2006-02-06 16:36:42 EST
I have found the bug which coused the trouble.

Now I am ablt to compile blender on the i686 arch. So I have commited the
current version an initiate the build process on the buil system.

Best Regards:

Jochen Schmitt

Comment 11 Andreas Bierfert 2006-02-06 16:38:56 EST
Just while reading this mail I also found that it was missing -lalut from the
linker options... binary seems to run fine here on i686 or should I say start up... 

Please let me know your progress... 
Comment 12 Andreas Bierfert 2006-02-08 01:46:42 EST
I see that a new blender has been pushed. Are these issues resolved now?
Comment 13 Jochen Schmitt 2006-02-08 09:47:53 EST
The issue reported in this bug should be solved. If not, please give me any
feedback.

Best Regards:

Jochen Schmitt
Comment 14 Andreas Bierfert 2006-02-08 10:15:43 EST
Changed to needinfo... if I don't hear back till tomorrow I will close the bug.
Thanks for reporting.

Note You need to log in before you can comment on or make changes to this bug.