Bug 1796141 - Baremetal IPI - Metadata cleaning pre-installation is failing on HPE Virtual Install Devices
Summary: Baremetal IPI - Metadata cleaning pre-installation is failing on HPE Virtual ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Riccardo Pittau
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
: 1796154 (view as bug list)
Depends On:
Blocks: 1796154
TreeView+ depends on / blocked
 
Reported: 2020-01-29 17:18 UTC by Julia Kreger
Modified: 2020-06-01 20:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1796154 (view as bug list)
Environment:
Last Closed: 2020-06-01 20:10:22 UTC
Target Upstream Version:
jkreger: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift ironic-image pull 50 None closed Bug 1796141: Temporarily disable cleaning as a workaround 2020-06-01 20:06:37 UTC
Github openshift ironic-ipa-downloader pull 23 None closed Bug 1798491: Add a way to modify ipa image 2020-06-01 20:06:37 UTC
OpenStack Storyboard 2007229 None None None 2020-01-29 17:18:38 UTC

Description Julia Kreger 2020-01-29 17:18:38 UTC
Baremetal IPI installer process wipes disk metadata in advance of installation to prevent potential installation conflicts. Unfortunately we've discovered a class of virtual installation device on some HPE gear, which cannot be disabled from the bios settings with a recent HPE update. As such, we need to address this in the logic actually handling cleaning, and in the short term disable cleaning.

Comment 7 Stephen Benjamin 2020-02-24 14:37:57 UTC
Moving this to 4.5 as any new code will land there. When 4.5 code is merged, feel free to clone this to a 4.4 BZ and cherry pick.

Comment 10 Beth White 2020-05-12 15:24:27 UTC
*** Bug 1796154 has been marked as a duplicate of this bug. ***

Comment 14 Julia Kreger 2020-06-01 20:10:22 UTC
As far as I'm aware, this issue is no longer being encountered and the issues are, as far as I'm aware, resolved. Due to our inability to reproduce in our own labs and process limitations, I'm going to close this as notabug.


Note You need to log in before you can comment on or make changes to this bug.