Bug 1796154 - Baremetal IPI - Metadata cleaning pre-installation is failing on HPE Virtual Install Devices
Summary: Baremetal IPI - Metadata cleaning pre-installation is failing on HPE Virtual ...
Keywords:
Status: CLOSED DUPLICATE of bug 1796141
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.z
Assignee: Riccardo Pittau
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On: 1796141
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-29 17:47 UTC by Stephen Benjamin
Modified: 2020-05-12 15:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1796141
Environment:
Last Closed: 2020-05-12 15:24:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stephen Benjamin 2020-01-29 17:47:10 UTC
+++ This bug was initially created as a clone of Bug #1796141 +++

Baremetal IPI installer process wipes disk metadata in advance of installation to prevent potential installation conflicts. Unfortunately we've discovered a class of virtual installation device on some HPE gear, which cannot be disabled from the bios settings with a recent HPE update. As such, we need to address this in the logic actually handling cleaning, and in the short term disable cleaning.

Comment 1 Julia Kreger 2020-03-11 17:35:33 UTC
Stephen, is the expectation that we're going to be able to fix this in 4.3, or that we may be able to in 4.4. It looks like the IPA downloader patch didn't merge in time for 4.4, so we would need to backport it I believe.

Comment 2 Stephen Benjamin 2020-04-23 16:24:34 UTC
Sorry - I missed the needinfo on this one. https://bugzilla.redhat.com/show_bug.cgi?id=1796141 is open against 4.5. If it is resolved, then it can be backported to 4.4 with this BZ, and then we'd need another to backport to 4.3.

I'm reassigning this BZ to Ricardo who's the assignee on BZ#1796141. If we won't need to backport this, please close this BZ was WONTFIX. Thanks!

Comment 3 Beth White 2020-05-12 15:24:27 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1796141 is already backported to 4.3. Closing this bug as duplicate.

*** This bug has been marked as a duplicate of bug 1796141 ***


Note You need to log in before you can comment on or make changes to this bug.