Bug 1796185 - Enable pipelines for Knative and Kubernetes apps on import
Summary: Enable pipelines for Knative and Kubernetes apps on import
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Andrew Ballantyne
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1807133
TreeView+ depends on / blocked
 
Reported: 2020-01-29 19:33 UTC by Andrew Ballantyne
Modified: 2020-07-13 17:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Pipeline templates provided by the Operator had a Deployment Config specific deploy step, and would fail for Deployment and Knative Services Consequence: The Pipeline would build your app but not deploy it. Fix: Added support for the add flow to make use of the resource type as well as the builder to determine a Pipeline Result: Resource-specific support for Pipeline templates
Clone Of:
: 1796186 1807133 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:13:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
Enable pipelines for Knative and Kubernetes apps on import (1.59 MB, video/webm)
2020-03-03 21:56 UTC, spathak@redhat.com
no flags Details
Enable pipelines for Knative and Kubernetes apps on import screenshot (123.36 KB, image/png)
2020-03-04 14:36 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4476 None closed Bug 1796185: Add pipeline for resource and runtime 2020-06-30 18:52:39 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:13:55 UTC

Description Andrew Ballantyne 2020-01-29 19:33:22 UTC
Description of problem:
When selecting to add a pipeline from a runtime in the Add flows, it negates the understanding of the resource type that the pipeline may be in reference to.

Version-Release number of selected component (if applicable):
Noticed in 4.4, will need to be put back into 4.3.

How reproducible:


Steps to Reproduce:
1. Once a Pipeline is added to the `openshift` namespace with the appropriate label tying it to a runtime (ie pipeline.openshift.io/runtime:java - for the java runtime)
2. Navigate to the +Add flow and import from Git (or Dockerfile)
3. Notice that selecting the java runtime gets you the associated pipeline from the `openshift` namespace
4. Change your Resource type (Deployment, Deployment Config, Knative - if installed) and the pipeline is unaffected

Actual results:
Unable to associate a pipeline that may include internals for deployment vs knative for instance.


Expected results:
Being able to associate a pipeline to both a runtime as well as a resource type.


Additional info:
Logged first here https://issues.redhat.com/browse/ODC-2880 but needs backport to 4.3

Comment 3 spathak@redhat.com 2020-03-03 21:56:04 UTC
Created attachment 1667322 [details]
Enable pipelines for Knative and Kubernetes apps on import

Comment 4 spathak@redhat.com 2020-03-03 21:57:47 UTC
Verified on build : 4.5.0-0.ci-2020-03-03-154145
Chrome browser: 76.0.3809.132

Comment 5 spathak@redhat.com 2020-03-04 14:36:57 UTC
Created attachment 1667506 [details]
Enable pipelines for Knative and Kubernetes apps on import screenshot

Comment 7 errata-xmlrpc 2020-07-13 17:13:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.