Bug 1796186 - Enable pipelines for Knative and Kubernetes apps on import
Summary: Enable pipelines for Knative and Kubernetes apps on import
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.3.z
Assignee: Andrew Ballantyne
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1807133
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-29 19:34 UTC by Andrew Ballantyne
Modified: 2020-03-24 14:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1796185
Environment:
Last Closed: 2020-03-24 14:32:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
Enable pipelines for Knative and Kubernetes apps on import (1.45 MB, video/webm)
2020-03-03 16:56 UTC, spathak@redhat.com
no flags Details
Enable pipelines for Knative and Kubernetes apps on import-1 (72.04 KB, image/png)
2020-03-18 22:52 UTC, spathak@redhat.com
no flags Details
Enable pipelines for Knative and Kubernetes apps on import-2 (25.72 KB, image/png)
2020-03-18 22:53 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4509 None closed [release-4.3] Bug 1796186: Add pipeline for resource and runtime 2020-03-16 07:26:15 UTC
Red Hat Product Errata RHBA-2020:0858 None None None 2020-03-24 14:33:02 UTC

Description Andrew Ballantyne 2020-01-29 19:34:24 UTC
+++ This bug was initially created as a clone of Bug #1796185 +++

Description of problem:
When selecting to add a pipeline from a runtime in the Add flows, it negates the understanding of the resource type that the pipeline may be in reference to.

Version-Release number of selected component (if applicable):
Noticed in 4.4, will need to be put back into 4.3.

How reproducible:


Steps to Reproduce:
1. Once a Pipeline is added to the `openshift` namespace with the appropriate label tying it to a runtime (ie pipeline.openshift.io/runtime:java - for the java runtime)
2. Navigate to the +Add flow and import from Git (or Dockerfile)
3. Notice that selecting the java runtime gets you the associated pipeline from the `openshift` namespace
4. Change your Resource type (Deployment, Deployment Config, Knative - if installed) and the pipeline is unaffected

Actual results:
Unable to associate a pipeline that may include internals for deployment vs knative for instance.


Expected results:
Being able to associate a pipeline to both a runtime as well as a resource type.


Additional info:
Logged first here https://issues.redhat.com/browse/ODC-2880 but needs backport to 4.3

Comment 1 spathak@redhat.com 2020-03-03 16:56:49 UTC
Created attachment 1667265 [details]
Enable pipelines for Knative and Kubernetes apps on import

Comment 4 spathak@redhat.com 2020-03-18 22:52:29 UTC
Created attachment 1671274 [details]
Enable pipelines for Knative and Kubernetes apps on import-1

Comment 5 spathak@redhat.com 2020-03-18 22:53:22 UTC
Created attachment 1671275 [details]
Enable pipelines for Knative and Kubernetes apps on import-2

Comment 6 spathak@redhat.com 2020-03-18 22:54:29 UTC
Verified on build: 4.3.0-0.ci-2020-03-16-190421
Chrome browser: 76.0.3809.132

Comment 8 errata-xmlrpc 2020-03-24 14:32:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0858


Note You need to log in before you can comment on or make changes to this bug.