Bug 179624 - gstreamer-python does not work on x86_64
gstreamer-python does not work on x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer08-python (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Vander Stichele
Fedora Extras Quality Assurance
:
: 178298 (view as bug list)
Depends On:
Blocks: 177219 FE6Target
  Show dependency treegraph
 
Reported: 2006-02-01 13:44 EST by Thorsten Leemhuis
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 09:36:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2006-02-01 13:44:07 EST
Description of problem:
Python fails to import module gst with latest gstreamer-python in FE4 on x86_64

Version-Release number of selected component (if applicable):
gstreamer-python.x86_64 0:0.8.3-1

How reproducible:
Always

Steps to Reproduce:

[thl@truhe ~]$ rpm -q gstreamer-python
gstreamer-python-0.8.3-1
[thl@truhe ~]$ python
Python 2.4.1 (#1, May 16 2005, 15:15:14)
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gst
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
ImportError: No module named gst
>>> quit
'Use Ctrl-D (i.e. EOF) to exit.'
>>>

Works fine with an older version:
[thl@truhe ~]$ sudo rpm -Uvh --oldpackage gstreamer-python-0.8.1-6.x86_64.rpm
Preparing...                ########################################### [100%]
   1:gstreamer-python       ########################################### [100%]
[thl@truhe ~]$ python
Python 2.4.1 (#1, May 16 2005, 15:15:14)
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gst
>>>
[thl@truhe ~]$

Additional info:
The same problem probably happens with gstreamer-python08 in Fedora Extras
devel. I stumbled about it in FC4 after looking closer at this build problem:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/3582-istanbul-0.1.1-8/x86_64/build.log
(One needs to change the BR from gstreamer-python08 to gstreamer-python in the
spec of istanbul to build in on FC4)
Comment 1 Thorsten Leemhuis 2006-02-01 13:54:59 EST
Seems 
/usr/lib64/python2.4/site-packages/gst/__init__.py
/usr/lib64/python2.4/site-packages/gst/__init__.pyc
/usr/lib64/python2.4/site-packages/gst/__init__.pyo
are missing for some unknown reason in the x86_64 package
Comment 2 Ignacio Vazquez-Abrams 2006-03-07 22:32:41 EST
*** Bug 178298 has been marked as a duplicate of this bug. ***
Comment 3 Jef Spaleta 2006-03-07 22:48:01 EST
Thomas can you please review and apply this patch in a gstreamer08-python
rebuild in extras-development. John Ellson has provided the patch in extras-list
to address the issue of the missing __init__.py in the 64bit packages of
gstreamer08-python.  

-jef

 
--- gst/Makefile.am.orig        2006-03-07 22:04:59.000000000 -0500
+++ gst/Makefile.am     2006-03-07 22:05:41.000000000 -0500
@@ -5,7 +5,7 @@
 pkgpythondir = $(pythondir)/gst
 pkgpyexecdir = $(pyexecdir)/gst

-pygstdir = $(pkgpythondir)
+pygstdir = $(pkgpyexecdir)
 pygst_PYTHON = __init__.py

 pygstexecdir = $(pkgpyexecdir)
--- gst/Makefile.in.orig        2006-03-07 22:07:18.000000000 -0500
+++ gst/Makefile.in     2006-03-07 21:43:58.000000000 -0500
@@ -263,7 +263,7 @@
 common_cflags = $(PYGTK_CFLAGS) $(GST_CFLAGS) $(PYGST_CFLAGS) -fno-strict-aliasing
 common_libadd = $(GST_LIBS)
 common_ldflags = -module -avoid-version
-pygstdir = $(pkgpythondir)
+pygstdir = $(pkgpyexecdir)
 pygst_PYTHON = __init__.py
 pygstexecdir = $(pkgpyexecdir)
 pygstexec_LTLIBRARIES = _gst.la $(interface_lib) $(play_lib)
Comment 4 Jef Spaleta 2006-03-28 07:29:15 EST
i believe this has been fixed

-jef
Comment 5 Thorsten Leemhuis 2006-03-28 09:36:15 EST
(In reply to comment #4)
> i believe this has been fixed

confirmed

Note You need to log in before you can comment on or make changes to this bug.