Bug 1796423 - [buildcop] release-openshift-origin-installer-e2e-aws-upgrade-4.1-stable-to-4.1-nightly failing on: error waiting for deployment \"dp\" to match expectation
Summary: [buildcop] release-openshift-origin-installer-e2e-aws-upgrade-4.1-stable-to-4...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1796017
TreeView+ depends on / blocked
 
Reported: 2020-01-30 12:15 UTC by Maciej Szulik
Modified: 2020-05-13 21:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1796017
Environment:
Last Closed: 2020-05-13 21:55:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:55:44 UTC

Description Maciej Szulik 2020-01-30 12:15:56 UTC
+++ This bug was initially created as a clone of Bug #1796017 +++

+++ This bug was initially created as a clone of Bug #1794813 +++

Description of problem:

e2e upgrade test fails for release 4.1 on

fail [k8s.io/kubernetes/test/e2e/upgrades/apps/deployments.go:166]: Expected error:
    <*errors.errorString | 0xc0003fbf30>: {
        s: "error waiting for deployment \"dp\" status to match expectation: deployment status: v1.DeploymentStatus{ObservedGeneration:3, Replicas:2, UpdatedReplicas:2, ReadyReplicas:2, AvailableReplicas:2, UnavailableReplicas:0, Conditions:[]v1.DeploymentCondition{v1.DeploymentCondition{Type:\"Progressing\", Status:\"True\", LastUpdateTime:v1.Time{Time:time.Time{wall:0x0, ext:63715480704, loc:(*time.Location)(0x90bdf20)}}, LastTransitionTime:v1.Time{Time:time.Time{wall:0x0, ext:63715480680, loc:(*time.Location)(0x90bdf20)}}, Reason:\"NewReplicaSetAvailable\", Message:\"ReplicaSet \\\"dp-57cc5d77b4\\\" has successfully progressed.\"}, v1.DeploymentCondition{Type:\"Available\", Status:\"True\", LastUpdateTime:v1.Time{Time:time.Time{wall:0x0, ext:63715482612, loc:(*time.Location)(0x90bdf20)}}, LastTransitionTime:v1.Time{Time:time.Time{wall:0x0, ext:63715482612, loc:(*time.Location)(0x90bdf20)}}, Reason:\"MinimumReplicasAvailable\", Message:\"Deployment has minimum availability.\"}}, CollisionCount:(*int32)(nil)}",
    }
   error waiting for deployment "dp" status to match expectation: deployment status: v1.DeploymentStatus{ObservedGeneration:3, Replicas:2, UpdatedReplicas:2, ReadyReplicas:2, AvailableReplicas:2, UnavailableReplicas:0, Conditions:[]v1.DeploymentCondition{v1.DeploymentCondition{Type:"Progressing", Status:"True", LastUpdateTime:v1.Time{Time:time.Time{wall:0x0, ext:63715480704, loc:(*time.Location)(0x90bdf20)}}, LastTransitionTime:v1.Time{Time:time.Time{wall:0x0, ext:63715480680, loc:(*time.Location)(0x90bdf20)}}, Reason:"NewReplicaSetAvailable", Message:"ReplicaSet \"dp-57cc5d77b4\" has successfully progressed."}, v1.DeploymentCondition{Type:"Available", Status:"True", LastUpdateTime:v1.Time{Time:time.Time{wall:0x0, ext:63715482612, loc:(*time.Location)(0x90bdf20)}}, LastTransitionTime:v1.Time{Time:time.Time{wall:0x0, ext:63715482612, loc:(*time.Location)(0x90bdf20)}}, Reason:"MinimumReplicasAvailable", Message:"Deployment has minimum availability."}}, CollisionCount:(*int32)(nil)}
not to have occurred

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-upgrade-4.1-stable-to-4.1-nightly/9

Version-Release number of selected component (if applicable):
4.1.z

How reproducible:
e2e upgrade test failure

Steps to Reproduce:
Run release-openshift-origin-installer-e2e-aws-upgrade-4.1-stable-to-4.1-nightly test

Actual results:
test fails

Expected results:
test passes

Additional info:

--- Additional comment from Maciej Szulik on 2020-01-29 13:15:13 CET ---

Fix in https://github.com/openshift/origin/pull/24473

--- Additional comment from Maciej Szulik on 2020-01-30 13:15:30 CET ---

This is targeting 4.3.z and that is already included with the latest release of k8s. Moving to modified.

Comment 1 Maciej Szulik 2020-01-30 12:18:20 UTC
This is already included with the latest release of k8s. Moving to modified.

Comment 5 errata-xmlrpc 2020-05-13 21:55:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.