Bug 1796658 - Update patternfly-catalog-view-extension and fix catalog tile heights/truncation [openshift-4.5]
Summary: Update patternfly-catalog-view-extension and fix catalog tile heights/truncat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: ralpert
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1805330 1808490
TreeView+ depends on / blocked
 
Reported: 2020-01-30 21:19 UTC by ralpert
Modified: 2020-07-13 17:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Catalog tiles had some size and responsiveness issues due to their reliance on an underlying PatternFly component. We updated the library the tiles are pulled from, brought it into OpenShift, and fixed the tile sizes. The issue has been resolved.
Clone Of:
: 1805330 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:13:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4168 None closed Bug 1796658: Fix catalog tile truncation and responsiveness 2020-06-23 08:22:42 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:13:55 UTC

Description ralpert 2020-01-30 21:19:38 UTC
Description of problem:
We have made some bug fixes to the Catalog Tiles used in OpenShift and need to pull in the latest version of patternfly/catalog-view-extensions. We also need to change the heights of the tiles and make them fixed width to avoid some UI bugs that were introduced earlier in 4.4. See https://issues.redhat.com/browse/CONSOLE-2013.

Version-Release number of selected component (if applicable):


How reproducible:
Very

Steps to Reproduce:
1. Go to OperatorHub, Developer Catalog, or topology empty state
2. Tiles will be responsive and truncate text oddly

Actual results:
Tiles are responsive and handle truncation poorly, so they're huge.

Expected results:
Tiles are not responsive and handle truncation more elegantly so we can reduce the size.

Additional info:

Comment 4 XiaochuanWang 2020-03-06 06:54:15 UTC
Now the grid display Catalog Tiles and Operators Tiles clearly according to the expect fix from PR.

Verified on 4.5.0-0.ci-2020-03-04-223611

Comment 6 errata-xmlrpc 2020-07-13 17:13:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.