Bug 1805330 - Update patternfly-catalog-view-extension and fix catalog tile heights/truncation [openshift-4.4]
Summary: Update patternfly-catalog-view-extension and fix catalog tile heights/truncat...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: ralpert
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1808490 (view as bug list)
Depends On: 1796658
Blocks: 1808490
TreeView+ depends on / blocked
 
Reported: 2020-02-20 16:47 UTC by ralpert
Modified: 2020-06-30 13:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1796658
: 1808490 (view as bug list)
Environment:
Last Closed: 2020-04-29 14:23:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
Operator Hub Tiles (588.25 KB, image/png)
2020-03-09 03:00 UTC, Yadan Pei
no flags Details
Developer Catalog Items (424.75 KB, image/png)
2020-03-09 03:02 UTC, Yadan Pei
no flags Details
Developer Catalog Items At Mobile View (203.43 KB, image/png)
2020-03-09 03:03 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4638 0 None closed [release-4.4] Bug 1805330: Fix catalog tile truncation and responsiveness 2020-06-30 09:54:44 UTC

Description ralpert 2020-02-20 16:47:10 UTC
+++ This bug was initially created as a clone of Bug #1796658 +++

Description of problem:
We have made some bug fixes to the Catalog Tiles used in OpenShift and need to pull in the latest version of patternfly/catalog-view-extensions. We also need to change the heights of the tiles and make them fixed width to avoid some UI bugs that were introduced earlier in 4.4. See https://issues.redhat.com/browse/CONSOLE-2013.

Version-Release number of selected component (if applicable):


How reproducible:
Very

Steps to Reproduce:
1. Go to OperatorHub, Developer Catalog, or topology empty state
2. Tiles will be responsive and truncate text oddly

Actual results:
Tiles are responsive and handle truncation poorly, so they're huge.

Expected results:
Tiles are not responsive and handle truncation more elegantly so we can reduce the size.

Additional info:

Comment 4 ralpert 2020-02-28 16:08:34 UTC
*** Bug 1808490 has been marked as a duplicate of this bug. ***

Comment 6 Yadan Pei 2020-03-09 03:00:35 UTC
Created attachment 1668533 [details]
Operator Hub Tiles

- Operator Hub catalog items are shown in the same height for every row, but not every row has the same height, this is intentional 
- Text in catalog are truncated using .... when it is long

Comment 7 Yadan Pei 2020-03-09 03:02:29 UTC
Created attachment 1668534 [details]
Developer Catalog Items

Same as Developer Catalog, the catalog items can be shown in correct height in different conditions

Comment 8 Yadan Pei 2020-03-09 03:03:20 UTC
Created attachment 1668535 [details]
Developer Catalog Items At Mobile View

Catalog items are shown correctly at Mobile View

Comment 9 Yadan Pei 2020-03-09 03:05:25 UTC
Moving to VERIFIED based on comment 6, comment 7 and comment 8

Verified on 4.4.0-0.nightly-2020-03-08-213224


Note You need to log in before you can comment on or make changes to this bug.