Bug 179692 - replace bitmap fonts in text area with TrueType font
replace bitmap fonts in text area with TrueType font
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: FutureFeature, i18n
: 183164 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 23:14 EST by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-08 19:43:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample text document (6.57 KB, application/vnd.oasis.opendocument.text)
2006-02-03 02:01 EST, Lawrence Lim
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 61841 None None None Never

  None (edit)
Description Lawrence Lim 2006-02-01 23:14:40 EST
Description of problem:
Is it possible to use TrueType font instead of Bitmap in the text input area? 

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.1.1-5.2

How reproducible:
Always

Steps to Reproduce:
1.start oowriter in zh_CN or zh_TW locale
2.
3.
  
Actual results:
bitmap font is used for font size 8-12

Expected results:
truetype font instead

Additional info:
Comment 1 Caolan McNamara 2006-02-02 05:24:59 EST
OOo should only use truetype or type1 fonts, in theory at least.
By "text input area" do you mean writer itself ?
Is this with or without the fonts-chinese installed, "with" I assume ?
What font is shown in the font bar in writer when the bad looking letters are
selected "AR PL SungtiL GB" ?
And what is the output of echo $LANG

It would be really good if you could simply attach a document which demonstrates
this so I can see what the problem looks like.

The way this is supposed to work is that writer has a list of fonts which it
would like to use for zh_cn and zh_tw and we ask fontconfig to give up an
appropiate replacement font if it doesn't exist.
Comment 2 Tim Mayberry 2006-02-02 21:48:28 EST
I had a talk to Lawrence and I think I understand the issue. The recently the
fontconfig configuration was changed so that the default font for those locales
using fontconfig is AR PL ShanHeiSun Uni which you see if you do 
$ LANG=zh_TW.UTF-8 fc-match 
uming.ttf: "AR PL ShanHeiSun Uni" "Regular"

This font has embedded bitmaps aswell as outline glyphs. This is easy to see if
in oowriter you select that font and type some text with a point size of 8-12 as
Lawrence indicated, if you then select a range of text in that font and change
the point size to 13 you can immediately see that the embedded bitmaps are no
longer used.

I think what is needed is a way to tell open office to use the outline glyphs
rather than the embedded bitmaps either globally or for that particular font, I
don't know if oowriter has the facility to do that.

I know it can be done via fontconfig, but I tried it and it seems that oowriter
doesn't have support for the "embeddedbitmap" fontconfig directive which is
unsurprising as it is relatively new.
Comment 3 Lawrence Lim 2006-02-03 02:01:37 EST
Created attachment 124096 [details]
sample text document

Thanks for the clarification. 

Please find attached the sample document requested and start owwriter in the
zh_CN locale.
Comment 4 Caolan McNamara 2006-02-06 07:32:47 EST
So you want it the way it looks from

> export SAL_EMBEDDED_BITMAP_PRIORITY=1
> oowriter
Comment 5 Lawrence Lim 2006-02-07 02:41:46 EST
RE: Comment #4
Yes, that is what I would like to propose in the writer. However, we still want
to keep the bitmaps font in the menu. Is that possible? ;)
Comment 6 Caolan McNamara 2006-02-07 06:46:27 EST
I propose to honour the embedbitmap flag from fontconfig, so things would end up
 handled the same as the rest of the gnome desktop. i.e. embeddedbitmaps would
end up being disabled everywhere that this particular font (and other such
marked ones) is used, whether gnome or OOo. menu or writer canvas
Comment 7 Lawrence Lim 2006-02-08 19:43:52 EST
Yup, I understand. In that case, I am happy with the current setting. Thank you. :-)
Comment 8 Caolan McNamara 2006-02-09 06:25:38 EST
oky doky, well anyway http://qa.openoffice.org/issues/show_bug.cgi?id=61841 is
my patch to honour the fontconfig "embeddedbitmap" setting. Though of course our
current fontconfig setting for this particular font is "true" so no change would
take place for the sample document.
Comment 9 Caolan McNamara 2006-02-27 04:50:41 EST
*** Bug 183164 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.