Bug 1797133 - etcd: certagent can not parse escaped IPv6 addresses
Summary: etcd: certagent can not parse escaped IPv6 addresses
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1797153
Blocks: 1797636
TreeView+ depends on / blocked
 
Reported: 2020-02-01 00:38 UTC by Sam Batschelet
Modified: 2020-04-14 14:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1797153 1797636 (view as bug list)
Environment:
Last Closed: 2020-02-22 00:41:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kubecsr pull 18 0 None closed Bug 1797133: cherry-pick pkg/certagent: add support for passing escaped IPv6 addresses 2020-10-18 13:02:24 UTC

Description Sam Batschelet 2020-02-01 00:38:46 UTC
Description of problem: For example passing --ipaddrs=[::1] would currently fail as this is not a valid IPv6 address. The reason we want this ability is to simplify IPv6 validation as we do not need to worry about changing the format of the address before passing it to the agent. If the underlying IPv6 address is valid kube-client-agent will do the right thing and handle unescaping for free.


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. pass escaped ipv6 address to certagent
2.
3.

Actual results: failure


Expected results: address is handled


Additional info:


Note You need to log in before you can comment on or make changes to this bug.