Bug 1798130 - Invalid descriptor prevents operand details from displaying
Summary: Invalid descriptor prevents operand details from displaying
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1827656 (view as bug list)
Depends On: 1797727
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-04 15:55 UTC by Samuel Padgett
Modified: 2020-04-30 01:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the console would fail to show an operand if an invalid OLM descriptor was set by an operator. The console now tolerates invalid descriptors and will show the operand details.
Clone Of: 1797727
Environment:
Version: 4.3.0-0.ci-2020-01-29-133443 Cluster ID: 2ebfb326-d1fe-4061-a5ce-2858a7a90cf6 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0
Last Closed: 2020-04-30 01:28:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4241 None closed [release-4.3] Bug 1798130: add error boundary around OLM descriptors 2020-04-24 17:18:17 UTC
Red Hat Product Errata RHBA-2020:1529 None None None 2020-04-30 01:28:21 UTC

Comment 4 Yadan Pei 2020-04-17 06:45:53 UTC
1. Install Red Hat Integration - 3scale operator
2. Go to Installed Operators -> Red Hat Integration - 3scale -> click YAML tab
        specDescriptors:
          - description: Wildcard domain as configured in the API Manager object
            displayName: Wildcard Domain
            path: wildcardDomain    // change this line
            x-descriptors:
              - 'urn:alm:descriptor:com.tectonic.ui:label'
3. Change spec.specDescriptors.path to 'system' and Save yaml, it will look like below after changes
        specDescriptors:
          - description: Wildcard domain as configured in the API Manager object
            displayName: Wildcard Domain
            path: system      // this line is changed
            x-descriptors:
              - 'urn:alm:descriptor:com.tectonic.ui:label'
4. Create API Manager instance and view its details, now the details can be shown without crash, we can also see JS error in F12 which was skipped

Error: "Minified React error #31; visit https://reactjs.org/docs/error-decoder.html?invariant=31&args[]=object%20with%20keys%20%7BappSpec%2C%20sidekiqSpec%7D&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings. "


Verified on     4.3.0-0.nightly-2020-04-17-001437

Comment 5 Robb Hamilton 2020-04-27 18:48:56 UTC
*** Bug 1827656 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2020-04-30 01:28:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1529


Note You need to log in before you can comment on or make changes to this bug.