Bug 1827656 - Operator Details - Tab resource - resource details returns React error returned in 4.3.13
Summary: Operator Details - Tab resource - resource details returns React error return...
Keywords:
Status: CLOSED DUPLICATE of bug 1798130
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-24 13:03 UTC by Sho
Modified: 2020-04-27 20:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-27 18:48:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of React error (349.34 KB, image/png)
2020-04-24 13:03 UTC, Sho
no flags Details
No error on Subscription details page when Multicluster Subscription Operator is installed directly (257.81 KB, image/png)
2020-04-27 17:40 UTC, Robb Hamilton
no flags Details
Bug is fixed (290.43 KB, image/png)
2020-04-27 18:49 UTC, Robb Hamilton
no flags Details

Description Sho 2020-04-24 13:03:23 UTC
Created attachment 1681468 [details]
Screenshot of React error

Description of problem:

A React error is displayed if I try to navigate to a resource detail in the Operator details page.

Version-Release number of selected component (if applicable):

4.3.13

How reproducible:

Always

Steps to Reproduce:
1.  I have RHACM installed.  Left Nav -> Operators -> Installed Operators.
2.  Click Multicluster Subscription Operator.
3.  There are two Subscription tabs; choose the second tab.
4.  Click any Subscription resource.
5.  Observe the React error.

Actual results:

React error.

Expected results:

See Subscription resource details.

Additional info:

Comment 1 Stephen Cuppett 2020-04-24 13:20:10 UTC
Setting target release to current development version (4.5) for investigation. Where fixes (if any) are required/requested for prior versions, cloned BZs will be created when appropriate.

Comment 2 Robb Hamilton 2020-04-27 17:39:23 UTC
I believe this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1798130.  I am not able to get RHACM installed (not clear on how as https://github.com/open-cluster-management/rhacm-docs appears outdated), but I was able to install Multicluster Subscription Operator directly and view the Subscription details page with no issues on a 4.3.13 cluster.

Comment 3 Robb Hamilton 2020-04-27 17:40:37 UTC
Created attachment 1682236 [details]
No error on Subscription details page when Multicluster Subscription Operator is installed directly

Comment 4 Samuel Padgett 2020-04-27 17:42:08 UTC
Generally this is caused by a mistake in the way the status descriptor is declared in the ClusterServiceVersion manifest. The runtime error for bad descriptors would have been handled in bug 1797727, but that will hide the descriptor with the problem. We should look at problematic descriptor to see what's wrong.

> There are two Subscription tabs; choose the second tab.

That's unfortunate. There is an OLM resource called Subscription that we should have a tab on the installed operators page. It sounds like ACM has a separate Subscription custom resource, so we have two tabs with the same name.

Comment 5 Samuel Padgett 2020-04-27 17:52:33 UTC
Can you attach the YAML for the ClusterServiceVersion resourcce you're looking at and the YAML for the Subscription resource that has the error? (Not the OLM Subscription, but the Subscription custom resource provided by the operator.) We shouldn't need a full ACM environment if we can get the YAML for those resources.

Comment 6 Robb Hamilton 2020-04-27 18:48:56 UTC
I was able to get RHACM installed on my 4.3.13 cluster and confirmed the bug is fixed by https://bugzilla.redhat.com/show_bug.cgi?id=1798130.

*** This bug has been marked as a duplicate of bug 1798130 ***

Comment 7 Robb Hamilton 2020-04-27 18:49:35 UTC
Created attachment 1682248 [details]
Bug is fixed

Comment 8 Samuel Padgett 2020-04-27 20:08:05 UTC
ACM has an incorrect status descriptor in its ClusterServiceVersion manifest, specifically:

          - description: The current status of the subscription
            displayName: Status
            path: statuses
            x-descriptors:
              - 'urn:alm:descriptor:text'

The `status.statuses` property is an object, which is not compatible with the `urn:alm:descriptor:text` descriptor.


Note You need to log in before you can comment on or make changes to this bug.