Bug 179825 - GroupSelector.glade is not found
GroupSelector.glade is not found
Status: CLOSED DUPLICATE of bug 179800
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-02-03 02:45 EST by Jasper O. Hartline
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-03 09:30:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jasper O. Hartline 2006-02-03 02:45:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
Upon running anaconda via Kadischi, a Fedora LiveCD generation utility, Anaconda gets to the accounts setup with the root password, and stops with an exception, GroupSelector.glade not found. 

Inspection of where this file actually exists, if it did was in package:

This is attributed to defined function findGladeFile() in /usr/lib/anaconda/gui.py
never looking towards /usr/lib/python2.4/site-packages/pirut for this file, which is where it does in fact exist.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. kadischi --graphical /pub/development -f /tmp/rawhide.iso
2. Choose keyboard, language, timezone and rootpassword, click next.
3. Exception occurs in def findGladeFile() in /usr/lib/anaconda/gui.py

Actual Results:  Recieved a fatal exception from Anaconda.

Expected Results:  GroupSelector.py should have been found, and I should have been taken to the package selection screens.

Additional info:

No additional information at this time.
Comment 1 Jasper O. Hartline 2006-02-03 03:01:24 EST
/usr/share/pirut/ui/GroupSelector.glade rather.
Here is the exception:
08:35:57 CRITICAL: Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 945, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 1305, in setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/usr/lib/anaconda/iw/package_gui.py", line 28, in getScreen
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 200, in
    xmlfn = getgladefunc(GLADE_FILE)
  File "/usr/lib/anaconda/gui.py", line 406, in findGladeFile
    raise RuntimeError, "Unable to find glade file %s"  %(fn,)
RuntimeError: Unable to find glade file /usr/share/anaconda/ui/GroupSelector.glade

Which is actually in /usr/share/pirut/ui
Comment 2 Paul Nasrat 2006-02-03 09:30:37 EST
Fixed yesterday

*** This bug has been marked as a duplicate of 179800 ***

Note You need to log in before you can comment on or make changes to this bug.