Bug 179826 - sound-juicer-2.13.4-1 uses gst 0.10.x.
sound-juicer-2.13.4-1 uses gst 0.10.x.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 180069 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2006-02-03 02:50 EST by sangu
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.13.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 14:34:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2006-02-03 02:50:16 EST
Description of problem:
Wrong sound-juicer.spec

http://cvs.fedora.redhat.com/viewcvs/devel/sound-juicer/sound-juicer.spec?rev=1.35&view=auto
[...]
%define gstreamer_version 0.8
[...]
BuildRequires:	gstreamer08-devel >= %{gstreamer_version}
BuildRequires:  gstreamer08-plugins-devel 

modify spec file like this
[...]
%define gstreamer_version 0.10.2
[...]
BuildRequires:	gstreamer-devel >= %{gstreamer_version}
BuildRequires:  gstreamer-plugins-base-devel 

Version-Release number of selected component (if applicable):
2.13.4

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sangu 2006-02-03 02:54:18 EST
anther wrong line.
[...]
Requires:	gstreamer08 >= %{gstreamer_version}
[...]

modify like this.
Requires:       gstreamer >= %{gstreamer_version}
Comment 2 Christopher Aillon 2006-02-03 18:19:16 EST
Hardly a blocker, but ok...
Comment 3 Jason 2006-02-05 10:11:04 EST
Thank you for updating sound-juicer to use gstreamer 0.10.  Can you please
update the dependency from gstreamer-plugins to gstreamer-plugins-base?

Thanks,
Comment 4 John (J5) Palmieri 2006-02-06 10:36:03 EST
*** Bug 180069 has been marked as a duplicate of this bug. ***
Comment 5 Alex Lancaster 2006-02-06 11:04:16 EST
I think this is now fixed in rawhide.  sound-juicer depends on gstreamer (0.10)
which, in turn, depends on gstreamer-plugins-base and gstreamer-plugins-good. 
Bit strange (it normally works the other way around), but it works (at least it
upgrades fine and runs, haven't ripped anything yet).
Comment 6 Alex Lancaster 2006-02-06 11:06:42 EST
(In reply to comment #5)
> I think this is now fixed in rawhide.  sound-juicer depends on gstreamer (0.10)
> which, in turn, depends on gstreamer-plugins-base and gstreamer-plugins-good. 

Forgot to say: hence no explicit Requires on any gstreamer-plugins-* package is
required, only a Requires on gstreamer.  At least that's how the gstreamer spec
file appears to be setup now.
Comment 7 Matthias Clasen 2006-02-07 14:34:04 EST
Fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.