Bug 179828 - About Me icon is not used for GDM face browser login, small UI complaints.
About Me icon is not used for GDM face browser login, small UI complaints.
Status: CLOSED DUPLICATE of bug 236393
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
David Lawrence
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 03:11 EST by Aaron Kurtz
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 04:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Kurtz 2006-02-03 03:11:51 EST
Description of problem:
The new condensed About Me utility is a good way to have users enter in personal
information. However, it replaced the Login photo application, but the photo or 
picture set doesn't actually show up in the GDM face browser login. It's just 
the usual default icons.

Also, gnome-about-me asks for a password to save changes even if none are made,
and it squashes icons, example being
http://hardsun.net/fedora/fedora-about-me.png when I use
http://hardsun.net/fedora/Magritte_applemod.png
Should I refile these picky points?

Version-Release number of selected component (if applicable):
control-center-2.13.90-1
Comment 1 Rahul Sundaram 2006-02-20 06:19:20 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Aaron Kurtz 2006-02-21 02:31:07 EST
I have updated to current rawhide, control-center-2.13.92-2

1. The About Me image is still not used in the face browser login.
Apparently GDM looks for ~/.gnome/photo for the icon. gdmphotosetup
sets this correctly, gnome-about-me does not. This is also used in
showing the screensaver unlock dialogue.

2. gnome-about-me does not ask for a password anymore if no changes are
made, because it doesn't ask for password if changes are made, bar
changing the password. This is a good thing.

3. The icon isn't cut off now, but it's shrunk. Example is at
http://hardsun.net/fedora/cfv-1.18.1-1.src.rpm
Comment 3 Aaron Kurtz 2006-02-21 02:32:39 EST
3. ... That should be http://hardsun.net/fedora/fedora-about-me2.png
Comment 4 Red Hat Bugzilla 2007-02-05 14:26:13 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 5 Bastien Nocera 2007-02-15 13:58:43 EST
(In reply to comment #2)
> I have updated to current rawhide, control-center-2.13.92-2
> 
> 1. The About Me image is still not used in the face browser login.
> Apparently GDM looks for ~/.gnome/photo for the icon. gdmphotosetup
> sets this correctly, gnome-about-me does not. This is also used in
> showing the screensaver unlock dialogue.

Actually, in recent versions about-me writes to ~/.face, which
gnome-screensaver, GDM, and about-me use.

Could you check that ~/.face is readable by other users? The output of "ls -ld
~/" and "ls -la ~/.face" would help. If you have SELinux enabled, please check
whether you get any errors regarding that file in your /var/log/messages.

> 3. The icon isn't cut off now, but it's shrunk. Example is at
> http://hardsun.net/fedora/cfv-1.18.1-1.src.rpm

Could you file another bug about this, after having tested with a recent version?
Comment 6 Matthew Miller 2007-04-06 14:19:56 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 7 Adriano Del Vigna 2007-04-20 21:13:15 EDT
I'm using FC7 test releases (6.92). The problem with the GDM face icon still
persists.

Steps to reproduce the problem today:

1.) Go to 'System->Preferences->Personal->About Me'
2.) Click in the upper left image button
3.) Choose an image file (I choosed one of the standard in
/usr/share/pixmaps/faces/race-car...)
4.) Click on 'Close' button
5.) Log out
6.) At Login screen (GDM) press CTRL+ALT+BACKSPACE (to restart X server)

The face icon did not changed after the change in preferences.
Comment 8 Miloslav Trmač 2007-04-29 16:08:18 EDT
gnome-about-me creates ~/.face with permissions 0664, and gdm ignores the file
because it is group-writable.
Comment 9 Bastien Nocera 2007-04-30 04:12:01 EDT
(In reply to comment #8)
> gnome-about-me creates ~/.face with permissions 0664, and gdm ignores the file
> because it is group-writable.

It's a dupe of bug 236393 (which was filed later, but has a patch already).

*** This bug has been marked as a duplicate of 236393 ***

Note You need to log in before you can comment on or make changes to this bug.