Bug 179844 - "Openoffice.org has crashed"
"Openoffice.org has crashed"
Status: CLOSED DUPLICATE of bug 179519
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 179936 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 07:19 EST by Chris Chabot
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 05:49:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Chabot 2006-02-03 07:19:24 EST
Description of problem:

I start up ooffice, and i get a crash dump screen. System is a fully uptodate
(feb 3rd) fedora core development, no special gimicks, actually had a clean
install only this morning! Hardware is a SATA HD, 3Ghz P4 x86_64 cpu (but
running FC i386, not _64 version) with HT enabled and running:
# rpm -qa | grep kernel
kernel-devel-2.6.15-1.1895_FC5
kernel-smp-2.6.15-1.1895_FC5

ooffice version is:

# rpm -qa | grep openoffice
openoffice.org-graphicfilter-2.0.1.1-9.2
openoffice.org-calc-2.0.1.1-9.2
openoffice.org-draw-2.0.1.1-9.2
openoffice.org-math-2.0.1.1-9.2
openoffice.org-xsltfilter-2.0.1.1-9.2
openoffice.org-impress-2.0.1.1-9.2
openoffice.org-core-2.0.1.1-9.2
openoffice.org-writer-2.0.1.1-9.2

Crash report:

Video Driver is probably i810
DESKTOP_SESSION is set to
libgcj version is libgcj-4.1.0-0.19
OpenOffice.org core rpm version is openoffice.org-core-2.0.1.1-9.2
0x646e690: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e690
0x646eede: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1eede
0xafe420:  + 0x420 (__kernel_sigreturn + 0x0)
0x66d0268: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x48268
(ucbhelper::cancelCommandExecution(com::sun::star::ucb::IOErrorCode,
com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&,
com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&,
rtl::OUString const&,
com::sun::star::uno::Reference<com::sun::star::ucb::XCommandProcessor> const&) +
0x170)
0x7ea5be4: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x2ebe4
0x7e97808: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x20808
0x7e84473: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0xd473
0x7e87d07: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x10d07
0x66a5bc5: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1dbc5
0x66a5d93: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1dd93
(ucb::Content::executeCommand(rtl::OUString const&, com::sun::star::uno::Any
const&) + 0x4b)
0x672b573: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x3e573
0x672d224: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x40224
(utl::UcbLockBytes::CreateLockBytes(com::sun::star::uno::Reference<com::sun::star::ucb::XContent>
const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>
const&, unsigned short,
com::sun::star::uno::Reference<com::sun::star::task::XInteractionHandler>
const&, utl::UcbLockBytesHandler*) + 0x2f6)
0x67369f2: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x499f2
0x6736c11: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x49c11
(utl::UcbStreamHelper::CreateStream(String const&, unsigned short,
utl::UcbLockBytesHandler*, unsigned char) + 0x33)
0x7468b00: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xb2b00
0x7560b5a: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1aab5a
0x7560ccb: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1aaccb
(SfxDispatcher::SfxDispatcher(SfxDispatcher*) + 0x27)
0x7465e89: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xafe89
0x7473d11: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xbdd11
(SfxApplication::SetApp(SfxApplication*) + 0xa7)
0x74740b4: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xbe0b4
(SfxApplication::GetOrCreate() + 0x50)
0x744fa54: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x99a54
0x7578383: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c2383
0x75784f9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c24f9
0x662aa5d: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x26a5d
0x662a753: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x26753
0x662a7ba: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x267ba
0x662c1e2: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x281e2
0x662a753: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x26753
0x662a80b: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x2680b
0x9f71f2: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x81f2
0x9f523b: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x623b
0x7ee31b7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x271b7
(desktop::Desktop::Main() + 0x913)
0x6899322: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e322
0x68993d5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e3d5 (SVMain()
+ 0x2b)
0x7edc98b: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x2098b (sal_main
+ 0x57)
0x7edc9d7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x209d7 (main + 0x27)
0x1a16b4: /lib/libc.so.6 + 0x156b4 (__libc_start_main + 0xdc)
0x80484a5: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x4a5
Comment 1 Chris Chabot 2006-02-06 03:41:49 EST
Update:

Even after upgrading to today's development/rawhide the crash still persists.
This includes kernel kernel-2.6.15-1.1909_FC5 and glibc-2.3.90-36.

Then i tried booting a non-smp kernel, and the crash went away!

The CPU is a very recent P4 with HT, and previously i was running a HT/SMP
kernel, booting a UP kernel makes ooffice work perfectly again. So i guess i'll
run that for a while :-)
Comment 2 Caolan McNamara 2006-02-06 05:46:51 EST
*** Bug 179936 has been marked as a duplicate of this bug. ***
Comment 3 Caolan McNamara 2006-02-06 05:49:36 EST

*** This bug has been marked as a duplicate of 179519 ***

Note You need to log in before you can comment on or make changes to this bug.