Bug 179936 - Openoffice.org 2.0 crash on startup
Openoffice.org 2.0 crash on startup
Status: CLOSED DUPLICATE of bug 179844
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 17:20 EST by Gavin Graham
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 05:46:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
current list of installed packages (34.44 KB, text/plain)
2006-02-04 21:56 EST, Jesus M. Rodriguez
no flags Details

  None (edit)
Description Gavin Graham 2006-02-03 17:20:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
After updating to the latest OO, it crashes on startup with the following output:
---start copy and paste here---
Video Driver is probably nvidia
DESKTOP_SESSION is set to
libgcj version is libgcj-4.1.0-0.20
OpenOffice.org core rpm version is openoffice.org-core-2.0.1.1-9.2
0x6696690: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e690
0x6696ede: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1eede
0x113420:  + 0x420 (__kernel_sigreturn + 0x0)
0x544fd48: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x45d48 (ucbhelper::cancelCommandExecution(com::sun::star::ucb::IOErrorCode, com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&, rtl::OUString const&, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandProcessor> const&) + 0x170)0x1f15544: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x2d544
0x1f07168: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x1f168
0x1ef3dd3: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0xbdd3
0x1ef7667: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0xf667
0x54256a5: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1b6a5
0x5425873: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1b873 (ucb::Content::executeCommand(rtl::OUString const&, com::sun::star::uno::Any const&) + 0x4b)
0xeeae33: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x3be33
0xeecae4: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x3dae4 (utl::UcbLockBytes::CreateLockBytes(com::sun::star::uno::Reference<com::sun::star::ucb::XContent> const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, unsigned short, com::sun::star::uno::Reference<com::sun::star::task::XInteractionHandler> const&, utl::UcbLockBytesHandler*) + 0x2f6)
0xef62b2: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x472b2
0xef64d1: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x474d1 (utl::UcbStreamHelper::CreateStream(String const&, unsigned short, utl::UcbLockBytesHandler*, unsigned char) + 0x33)
0x1c44960: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xa2960
0x1d3c9ba: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19a9ba
0x1d3cb2b: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19ab2b (SfxDispatcher::SfxDispatcher(SfxDispatcher*) + 0x27)
0x1c41ce9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x9fce9
0x1c4fb71: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xadb71 (SfxApplication::SetApp(SfxApplication*) + 0xa7)
0x1c4ff14: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xadf14 (SfxApplication::GetOrCreate() + 0x50)
0x1c2b8b4: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x898b4
0x1d541e3: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b21e3
0x1d54359: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b2359
0x535d1bd: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x251bd
0x535ceb3: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x24eb3
0x535cf1a: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x24f1a
0x535e942: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x26942
0x535ceb3: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x24eb3
0x535cf6b: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x24f6b
0x70c61f2: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x81f2
0x70c423b: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x623b
0x21b2b7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x262b7 (desktop::Desktop::Main() + 0x913)
0x4d8162: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x86162
0x4d8215: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x86215 (SVMain() + 0x2b)
0x214a8b: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1fa8b (sal_main + 0x57)
0x214ad7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1fad7 (main + 0x27)
0x33e784: /lib/libc.so.6 + 0x15784 (__libc_start_main + 0xdc)
0x80484c5: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4c5
---end copy and paste here---
Downgrading to .8.2 will now give the same result too.

Version-Release number of selected component (if applicable):
openoffice.org-base-2.0.1.1-9.2

How reproducible:
Always

Steps to Reproduce:
1. Update to openoffice.org-base-2.0.1.1-9.2.i386.rpm using yumex to solve any dependancies
2. Start OO
3. Crash Dialogue pops up.
  

Actual Results:  OO crashes on start

Expected Results:  OO should run

Additional info:
Comment 1 Jesus M. Rodriguez 2006-02-04 21:52:30 EST
I have a similar openoffice not starting problem.

package versions
-----------------
   rpm -qa | grep office
openoffice.org-core-2.0.1.1-9.2
openoffice.org-writer-2.0.1.1-9.2
openoffice.org-draw-2.0.1.1-9.2
openoffice.org-graphicfilter-2.0.1.1-9.2
openoffice.org-calc-2.0.1.1-9.2
openoffice.org-math-2.0.1.1-9.2
openoffice.org-impress-2.0.1.1-9.2
openoffice.org-xsltfilter-2.0.1.1-9.2


Clicking on the office icons anywhere in the UI causes the Open Office
splash screen to appear.  The progress bar gets about 1/4 of the way
then it disappears.

Hoping to get more detailed information, I started oowriter (ooimpress,
and oocalc) from the command line.  All did the same thing.
Comment 2 Jesus M. Rodriguez 2006-02-04 21:56:32 EST
Created attachment 124192 [details]
current list of installed packages

Including a list of the currently installed packages on my system.
rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}:%{ARCH}\n" | sort >
current_pkgs.txt
Comment 3 Caolan McNamara 2006-02-06 05:46:49 EST

*** This bug has been marked as a duplicate of 179844 ***

Note You need to log in before you can comment on or make changes to this bug.