Bug 1798565 - internal compiler error: in get_fns, at cp/tree.c:2507 (gcc 10)
Summary: internal compiler error: in get_fns, at cp/tree.c:2507 (gcc 10)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 32
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: GCC10 1799125
TreeView+ depends on / blocked
 
Reported: 2020-02-05 15:23 UTC by Mattias Ellert
Modified: 2020-10-05 08:33 UTC (History)
11 users (show)

Fixed In Version: 10.0.1-0.8.fc32 10.0.1-0.8.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-23 05:12:39 UTC
Type: Bug


Attachments (Terms of Use)
Preprocessed source (186.04 KB, application/x-bzip)
2020-02-05 16:20 UTC, Mattias Ellert
no flags Details


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 93597 P1 RESOLVED [10 Regression] ICE in get_fns since r10-6219 2020-02-23 05:07:20 UTC

Description Mattias Ellert 2020-02-05 15:23:12 UTC
Description of problem:

With the update from gcc-10.0.1-0.5.fc32 to gcc-10.0.1-0.6.fc32 the build of HepMC3 started failing with an internal compiler error. This happens for all architectures. The package failed the mass rebuild:

https://koji.fedoraproject.org/koji/buildinfo?buildID=1433152

Version-Release number of selected component (if applicable):

gcc-10.0.1-0.6.fc32
gcc-10.0.1-0.7.fc32

How reproducible:

Always

Steps to Reproduce:
1. Rebuild HepMC3 in rawhide

Actual results:

Failure due to internal compiler error.

Expected results:

Successful build

Additional info:

This is a regression from gcc-10.0.1-0.5.fc32. If I download the RPMs from koji for the gcc-10.0.1-0.5.fc32 and install them in a rawhide mock changeroot, the HepMC3 package can be built in this environment.

Comment 1 Marek Polacek 2020-02-05 15:28:34 UTC
I will need a preprocessed source file to look at this ICE; could you perhaps run an x86_64 scratch build with something like
make ... || (tar cf - /tmp/cc*.out | bzip2 -9 | uuencode cc.tar.bz2)
?

Comment 2 Jakub Jelinek 2020-02-05 16:19:43 UTC
Filed upstream as http://gcc.gnu.org/PR93597

Comment 3 Mattias Ellert 2020-02-05 16:20:09 UTC
Created attachment 1657951 [details]
Preprocessed source

Comment 4 Ben Cotton 2020-02-11 16:39:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.


Note You need to log in before you can comment on or make changes to this bug.