Bug 1798596 - take into consideration all instance states when deleting a machine
Summary: take into consideration all instance states when deleting a machine
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Alberto
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks: 1798597 1799034 1804596
TreeView+ depends on / blocked
 
Reported: 2020-02-05 15:51 UTC by Alberto
Modified: 2020-05-15 16:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1798597 1799034 1804596 (view as bug list)
Environment:
Last Closed: 2020-05-15 16:02:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-api-provider-aws pull 291 None closed Bug 1798596: take into consideration all instance states for deletion 2020-05-14 10:36:40 UTC

Description Alberto 2020-02-05 15:51:41 UTC
Description of problem:
In aws instances with a provider state different than running might be leaked when deleting.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
Create a machineSet.
Delete the machineSet before the instances get to running.
Check aws console.

Actual results:
Instances are leaked if they don't get to running.

Expected results:
Instances are deleted

Additional info:

Comment 2 Milind Yadav 2020-02-07 08:58:09 UTC
Description of problem:
In aws instances with a provider state different than running might be leaked when deleting.

miyadav@miyadav bug1798596]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-02-06-170203   True        False         8h      Cluster version is 4.4.0-0.nightly-2020-02-06-170203


Steps to Test:
Create a machineSet.
Delete the machineSet before the instances get to running.
Check aws console.

Actual results:
Instances gets terminated 

Expected results:
Instances are Terminated

Additional info:


Note You need to log in before you can comment on or make changes to this bug.